2

The following is the output I get from running a full reindex via SSH:

Product Attributes index was rebuilt successfully in 00:00:07
Product Prices index was rebuilt successfully in 00:00:05
Catalog URL Rewrites index was rebuilt successfully in 00:00:45
Product Flat Data index was rebuilt successfully in 00:00:33
Category Flat Data index was rebuilt successfully in 00:00:00
Category Products index was rebuilt successfully in 00:00:02
Catalog Search Index index was rebuilt successfully in 00:01:13
Stock Status index was rebuilt successfully in 00:00:00
Tag Aggregation Data index was rebuilt successfully in 00:00:00
tugasunw@serv01 [~/public_html]# 

My current server configuration is as follows:

  • Siteground Shared Cloud Server
  • 4 x 3.0 GHz CPU Cores
  • CentOS
  • 8GB RAM
  • 80GB SSD

My current Magento store configuration includes the following:

  • Magento CE 1.9.2.x
  • 1 installation, 5 domains, 5 stores/store-views, 1 shared cart
  • 5414 Total Product Records
  • 3468 of 5414 are Currently Enabled Products
  • 505 of 3468 are catalog/search for display
  • Flat Catalog is ENABLED

My current SQL table statuses are as follows:

  • core_url_rewrite - 94,752 rows - 50MiB
  • ALL catalog_product_flat (1-5) - ~3379 rows - 5.1 MiB

I can provide more info if needed.

I'm looking to optimize my database, and hopefully reduce the time it takes for these reindexing processes. The website gets a fair amount of traffic, our main brand has had over 8k sessions the past 30 days. I'm not against beefing up the specs on the "shared" server, but VPS is too expensive right now.

Any information or advice is greatly appreciated!

  • your issue only at indexing?,as per as your share details indexing time is soo good – Amit Bera Jun 23 '16 at 17:07
2

As per as,your share details,

i have understand,you indexing is time taken for Catalog Search.

Catalog Search Index index was rebuilt successfully in 00:01:13

For this case,we have do a general mistake,unnecessary we have enabling most of attribute for catalogSeach. We should enable only those attributes which are required for search.

For your case it may be main issue.

Your server configuration is very good as per as my view.

  • You need to some optimztionat at code level.
  • Avoid full load of model for a collection.

optimize Custom module which you have using.

  • Also one of import at database level , add index to every column of table
  • Looking back at this, I only have 10 attributes enabled for search – Steven J Apr 17 '18 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.