I read many article on SE but excuse me for not having knowledge of servers. I have tried turning off "Use Web Server Rewrites", but no change. I get 404 page which says "Not found", to which i used my knowledge of SE posts, which said to use index.php before the url e.g


and this work, but i have to put index.php manually. Why is it happening and how can i fix it because my "use web server rewrites" is turned off too.

  • 1
    add .htaccess file to your root directory which comes with fresh installation. Jun 21, 2016 at 13:52
  • Enable apache mod_rewrite and add .htaccess file to root. Then restart apache server Jun 21, 2016 at 14:02
  • If you don't want to use the rewrites, you could change the base urls in system > configuration > web to "http(s)://example.com/index.php/" instead of "http(s)://example.com/" Jun 21, 2016 at 15:27


Browse other questions tagged or ask your own question.