2

The currency symbol ($) is missing when changing the store view to Arabic Language.

I got two store views in my shop.

1 english and 1 arabic(ar_SA)

Standard currency is $ in all my shop.

On english store view the shop shows me $ 100.00 for example. On arabic store view I just get the Number itself like 100.00.

Can someone tell me why the $ is missing?

1

My Problem is solved.

Solution:

in lib/Zend/Locale/Data/ar_SA.xml

Must be removed the below code:

<numbers>
        <decimalFormats>
            <decimalFormatLength>
                <decimalFormat>
                    <pattern>#0.###;#0.###-</pattern>
                </decimalFormat>
            </decimalFormatLength>
        </decimalFormats>
        <currencyFormats>
            <currencyFormatLength>
                <currencyFormat>
                    <pattern>¤#0.00</pattern>
                </currencyFormat>
            </currencyFormatLength>
        </currencyFormats>
</numbers>

or this if exist

<numbers>
    <currencyFormats numberSystem="latn">
        <currencyFormatLength>
            <currencyFormat type="standard">
                <pattern>¤#0.00</pattern>
            </currencyFormat>
        </currencyFormatLength>
    </currencyFormats>
</numbers>

Reference: Currency symbol gets lost on specific store view

| improve this answer | |
0

Probably your its about your currency setup.

1-In admin panel, go to Admin > System > Configuration > Currency Set up.

2-Select currency that you want to be default from your base currency drop down.

3-Select the same currency in the Default Display Currency drop down and from the Allowed Currencies list.

4-Save

| improve this answer | |
  • This is not the solution to my problem it applied previously , i want another solution for my problem. – mahmoudismail Jun 19 '16 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.