0

After installing magento2 followed these steps to configure migration tool and then tried to migrate data using this link. At the end tried to execute the following command

Run the settings migration command:

bin/magento migrate:settings [-r|--reset] {<path to config.xml>}

in my case it is:

php mage22\bin\magento migrate:data [-r|--reset] E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml

I got this error in commamd prompt '--reset]' is not recognized as an internal or external command, operable program or batch file.

What was wrong and How to solve this.

2

Reset (-r OR --reset) is used to migrate from begining OR from start. If you are doing migration first time, just remove -r OR --reset. Also -r and --reset are alternate arguments, you can use ONLY one at a time (both works SAME).

Run this command :

php mage22\bin\magento migrate:data E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml

If you are trying more that once, try this:

php mage22\bin\magento migrate:data -r E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml

OR (works same as above)

php mage22\bin\magento migrate:data --reset E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml
  • Thanks for your reply. I've tried with the commands. I got this error: [Zend_Db_Adapter_Exception] SQLSTATE[HY000][1049] Base 'mage19' inconnue [PDOException] SQLSTATE[HY000][1049] Base 'mage19' inconnue migrate:data [-r|--reset] config – Saravanan DS Jun 17 '16 at 11:14
  • FYI: mage19 is my magento 1.9 version. – Saravanan DS Jun 17 '16 at 11:16
  • go to mage22 directory (cd mage22) and try : php bin\magento migrate:data -r E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml – Anil Suthar Jun 17 '16 at 11:26
  • Now Results this error: [Migration\Exception] Invalid config filename: E:\wamp\www\mage22\vendor\magento\data-migration-tool\etc\config.xml when changed config.xml.dist. When removed .dist from extension it results the Zend_Db_Adapter_Exception and PDOException – Saravanan DS Jun 17 '16 at 11:34
  • As per error, make sure, you config config.xml correctly. Check here : devdocs.magento.com/guides/v2.0/migration/… , Also check if config.xml exist at that location ? – Anil Suthar Jun 17 '16 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.