I am using Magento 2.0.5. When I run the composer update or composer install command it's showing the following warning.

Package fabpot/php-cs-fixer is abandoned, you should avoid using it. Use friendsofphp/php-cs-fixer instead.

enter image description here

I read https://github.com/paliarush/magento2-vagrant-for-developers/issues/46 but didn't get anything.

8 Answers 8


As the existing answers are not quite clear about it:

  1. this is not an error, only a warning. The abandoned package still exists, and Magento already replaced the dependency somewhere in version 2.1 so you don't have to worry about it.
  2. There seem to be cases where the warning prevents further installations. In that case, or if you want to get rid of the warning and use the current version of phpcsfixer (which is a dev tool and not required for Magento to operate), run these commands in your project root:

    composer remove fabpot/php-cs-fixer
    composer require --dev friendsofphp/php-cs-fixer

    Do not edit composer.json or even composer.lock directly to avoid conflicts!


It's a dependency in magento2 as it says there. They will change it soon. Magento uses that dependency so I don't think you can do anything about it.


I faced this same issue while installing Magento 2.1.8 using Composer.

This is only a warning, not an error. So, you can either ignore it or get rid of this warning by replacing the abandoned package with the required version of phpcsfixer in your Magento installation.

To fix this warning, run the following commands in your project root:

composer remove fabpot/php-cs-fixer
composer require --dev friendsofphp/php-cs-fixer 2.1.1

Note: This is a known issue #7310 and Magento already updated this dependency in the next major release Magento 2.2.

And one more thing, please do not edit composer.json or composer.lock file directly. It may create conflict when you upgrade the Magento in future.



Same with me from Magento 2.0.7 to 2.1.0, after installing patch MDVA-532 ( i am using php 5.6.20 ). Upgrade interrupted with the above message. Now nothing is working.

To fix this issue you need to do change in composer.json > "require-dev" the line:

-"fabpot/php-cs-fixer": "~1.2"


 -"friendsofphp/php-cs-fixer": "~2.0".

This removed fabpot/php-cs-fixer and installed friendsofphp/php-cs-fixer.

But upgrade also interrupted.

  • Magento will change it soon. Jul 12, 2016 at 7:10

I was able to resolve that through updating the composer.json file by replacing

"fabpot/php-cs-fixer": "~1.2"


"friendsofphp/php-cs-fixer": "~2.0"

and on the composer.lock replacing

"fabpot/php-cs-fixer": "0.4.0"


"friendsofphp/php-cs-fixer": "0.4.0"

and replacing

"fabpot/php-cs-fixer": "1.7.*"


"friendsofphp/php-cs-fixer": "2.0.*"

I met the same issue as well. But now I have resolved it already.

Replace "fabpot/php-cs-fixer": "~1.2" with -"friendsofphp/php-cs-fixer": "~2.0" both in composer.json and composer.lock file. Everything goes OK.


I had the same issue.

The problem was that I replaced fabpot/php-cs-fixer with friendsofphp/php-cs-fixer without replacing it in composer.lock as well. I ran

composer self-update
composer clear-cache

However, each time I tried to execute "composer update" it hung at updating dependencies. You can see this by running

composer update -vvv

So, at last, I rolled back the changes made to require-dev in composer.json and all went well updating Magento version to 2.1.10

Then, I decided to

composer remove fabpot/php-cs-fixer 

And then

composer require --dev friendsofphp/php-cs-fixer

However, installation fails because the symfony/console version requirements of friendsofphp/php-cs-fixer v.2.8 require PHP 7.1. That's the problem, because, Magento 2.1 does not support this version of php. Therefore, friendsofphp/php-cs-fixer can only be installed with Magento 2.2


It is fixed like this for my case.

  1. First run as administrator.
  2. Next, run composer install command in Node.js command prompt.

Not the answer you're looking for? Browse other questions tagged or ask your own question.