0

In Magento 1.9.2.4, when I go to System > Configuration > Web > Secure and set Use Secure URLs in Frontend to Yes, when I click Save, the field is set back to No.

Before clicking save: enter image description here

After clicking save: enter image description here

My goal is to make the whole site use https. All Secure Base * URLs are set correctly: enter image description here

There are no entries in the logs when this happens and there are no relevant script errors. I note that it says "Store View" next to the settings, however I've looked at the store views and website settings and they all say use the Default.

I also see the same problem with Use Secure URLs in Admin.

2

Seems that no admin settings could be saved. I went into the Magento database and set

core_config_data.web/secure/use_in_frontend to 1 core_config_data.web/secure/use_in_adminhtml to 1

This allowed me to save settings in admin, however it didn't fix my SSL. I had to the use the Admin UI to set “Use Secure URLs in Frontend” to No and then set it back to Yes, without clicking save in between. Same for the Admin HTML setting.

  • Thanks for adding your solution here. Don't forget to accept your own answer 48 hours after adding so that your question is marked as resolved :) – Anna Völkl Jun 18 '16 at 13:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.