1

Copied the below question from another forum. Has anybody been able to solve this? My cron is set up and is working. Emails marked as sent in back end but is being queued in core_email_queue. Spent 7 days trying to fix this issue using every other suggestion on other posts with no solution. Any help would be appreciated.

Copied Former question:- After installing the last patch 1.9.2.3 i can't send order notifications. When i run the cron it tries to send the E-Mail but i get the following error.

exception 'Zend_Mail_Transport_Exception' with message 'Unable to send mail. ' in /xxxxxxx/lib/Zend/Mail/Transport/Sendmail.php:156
Stack trace:
#0 /xxx/lib/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
#1 /xxx//lib/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#2 /xxx/app/code/core/Mage/Core/Model/Email/Queue.php(241): Zend_Mail->send()
#3 [internal function]: Mage_Core_Model_Email_Queue->send(Object(Mage_Cron_Model_Schedule))
#4 /xxx/app/code/core/Mage/Cron/Model/Observer.php(326): call_user_func_array(Array, Array)
#5 /xxx/app/code/core/Mage/Cron/Model/Observer.php(72): Mage_Cron_Model_Observer->_processJob(Object(Mage_Cron_Model_Schedule), Object(Mage_Core_Model_Config_Element))
#6 /xxx/app/code/core/Mage/Core/Model/App.php(1358): Mage_Cron_Model_Observer->dispatch(Object(Varien_Event_Observer))
#7 /xxx/app/code/core/Mage/Core/Model/App.php(1337): Mage_Core_Model_App->_callObserverMethod(Object(Mage_Cron_Model_Observer), 'dispatch', Object(Varien_Event_Observer))
#8 /xxx/app/Mage.php(448): Mage_Core_Model_App->dispatchEvent('default', Array)
#9 /xxx/cron.php(78): Mage::dispatchEvent('default')
#10 {main}

I have looked around and i know that this is a problem when you don't set the path to sendmail in backend back that is all correct. The mail function is active, too.

If i send an Email not over the queue so directly an forgotten Password its working well. Only the Queue functionality is broken. I have debugged a lot. The function _sendMail() in SendMail.php is called i write a text to the log files before and after but only the mail function isn't called its very strange.

Anyone an idea or have the same problem with that patch? I have seen in the other thread that there are a lot of problem with the new Patch.

Update:

The interesting thing is that my emails are queued in the core_email_queue with processed_at NULL. When i run the cron the processed date is set but the E-Mail isn't send. In the same Moment i get the error on top.

I have that problem only on my managed server. On my local machine the Email is sent what is very strange and i have no problems and no exception.

  • Please create a simple php file on your server called sendamil.php and add code <?php $msg = "First line of text\nSecond line of text"; $msg = wordwrap($msg,70); // send email mail("yourmail@domain.com","My subject",$msg); ?> change yourmail@domain.com with your mail id and hit file from url yourdomain.com/sendmail.php and check is it sending mail on your provided id or not. – Aman Alam Jun 11 '16 at 18:16
0

I was also facing a similar issue when I upgraded to 1.9.2.4. After debugging, I found that Magento 1.9 has started using mb_string() to strip out CSS styles and put them in the email itself so that it works in most email clients.

mb_string() method needs php extension mbstring to be installed. I installed it using the following cmd and the email started working.

yum install php54-mbstring

Not sure if your issue is the same but if you have not tried it then this is one pointer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.