1

i'm currently following the steps in

https://github.com/magento/code-migration

to install the Code Migration Tool (not data migrate) to my localhost.

i am facing a problem at the

Installation step

When i run composer install,

  1. it requires me username and password, saying Authentication required (repo.magento.com) ,

and i tried a few attemps, it just says

Invalid credential for https://repo.magento.com/packages.json, aborting.

i have done little research about the username and password on internet..

https://community.magento.com/t5/Just-Ask-Alan/Invalid-credentials-for-https-repo-magento-com-packages-json/m-p/23820#M127

They suggested to get the private key and public key from my magento marketplace account, i did that but it doesn't work.


  1. Also, the cmd doesn't allow me to type anything at the password.

Can anyone help me with this? Thanks >.<

  • I just successfully installed the tool with three commands: 1. git clone https://github.com/magento/code-migration.git m1tom2_code_migration_tool 2. cd m1tom2_code_migration_tool/ 3. composer install – ryanF Jun 13 '16 at 8:06
0

@Tine I use the auth.json approach, where on my Mac I have created a file ~/.composer/auth.json which looks like this:

{
    "http-basic": {
        "repo.magento.com": {
            "username": "MAGENTO_CONNECT_PUBLIC_KEY",
            "password": "MAGENTO_CONNECT_PRIVATE_KEY"
        }
    }
}
  • The ~/.composer directory has 755 permissions
  • The ~/.composer/auth.json file has 644 permissions

If you've followed the directions here: http://devdocs.magento.com/guides/v2.0/install-gde/prereq/connect-auth.html and created the auth.json file, then you shouldn't have any issues with permissions, as your credentials are accurate. Also, if you've verified that the directory/file permissions for ~/.composer/auth.json are correct, then there shouldn't be any problems with Composer accessing your credentials.

You could also try to clear your Composer cache to be thorough: https://getcomposer.org/doc/03-cli.md#clear-cache . If after clearing your cache, correctly creating/using the auth.json file, you're not able to install the migration tool, please post information about your environment....operating system, are you behind a firewall/proxy, etc.

  • Hi @ryanF, i am able to run the composer install . But it has an error full extraction path exceed maxpathlen 260. I tried to use composer install --prefer-source instead, clear composer cache, restart my pc. However, the same error is occuring. – Tine Jun 14 '16 at 7:55
  • @Tine looks like you're running into a Windows-specific error. Try taking a look at this: stackoverflow.com/a/30919348 . You might also want to just use something like this: github.com/paliarush/magento2-vagrant-for-developers (this is the officially supported Vagrnat VM for M2). It can be challenging at times to do development on an OS that is different than the one that your code will actually be deployed to (Unix or Linux). It might be better to learn how to use a form of Linux on your PC to get around these issues. Try to shorten your directory name to a single letter. – ryanF Jun 14 '16 at 8:50
  • thanks for the help, i'm able to run it already. But right now i'm stuck with the php bin/migrate.php migrateModuleStructure <src> <dst>. it shows this in the cmd: [2016-06-15 08:59:14][INFO]: Starting module structure converter ←[0;33m[2016-06-15 08:59:14][WARNING]: 0 modules were converted←[0m [2016-06-15 08:59:14][INFO]: Ending module structure converter any idea why is it like this? – Tine Jun 17 '16 at 3:06
  • the migration.log is like this : [2016-06-15 07:11:49][INFO]: Starting module structure converter [2016-06-15 07:11:49][WARNING]: 0 modules were converted [2016-06-15 07:11:49][INFO]: Ending module structure converter – Tine Jun 17 '16 at 3:08
  • hi @ryanF i have encounter a new problem, feel free to have a look stackoverflow.com/questions/38319940/… – Tine Jul 12 '16 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.