0

It all started when we moved the site and the email sending to a new server. Since then the new sale emails are sent twice, both to the customer and store owner. We are running Magento ver. 1.9.2.4

I tried out all the solutions described here, here and here.

Here is what I know so far:

  • there are no orphan records left on the Recipients table
  • there are no duplicate emails created in the database
  • cron is running and there are no duplicate crontasks created
  • I have set the copy that is sent to the store to BCC, I tried the Separate copy method but it's the same issue
  • Initially we used SMTP pro extension, as it was required by the old host company, the issue started when I changed these settings to the new server's settings. I disabled and uninstalled the extension, but it keeps sending duplicate emails.
  • There is a little difference between the two emails:

    1. visually the payment method is missing from one the emails
    2. comparing the two sources I found the following differences in the head section:

      2: Received: by 10.25.25.18 with SMTP id 18csp557327lfz;
      3: Thu, 9 Jun 2016 14:08:03 -0700 (PDT)
      4: X-Received: by 10.140.96.199 with SMTP id k65mr9670671qge.27.1465506483853;
      5: Thu, 09 Jun 2016 14:08:03 -0700 (PDT)
      
      2: Received: by 10.25.25.18 with SMTP id 18csp557131lfz;
      3: Thu, 9 Jun 2016 14:07:25 -0700 (PDT)
      4: X-Received: by 10.140.85.106 with SMTP id m97mr11482818qgd.41.1465506445409;
      5: Thu, 09 Jun 2016 14:07:25 -0700 (PDT)
      
      
      8: by mx.google.com with ESMTPS id s5si4428297qkc.169.2016.06.09.14.08.03
      8: by mx.google.com with ESMTPS id v124si1449328qhc.120.2016.06.09.14.07.24
      
      
      16: Message-Id:        
      <5759dab3.0577370a.5244e.45daSMTPIN_ADDED_MISSING@mx.google.com>
      
      16: Message-Id:
      <5759da8d.82fa8c0a.780ba.ffff8a35SMTPIN_ADDED_MISSING@mx.google.com>
      
      
      23: bh=dkKnBT4pJtbsDHYzbIX730M5P1u+x/BPP7K3dCdYeCE=; b=bKu0SmXGmuiU2GyuQbIcrR7OSH CRfnmNgcu8fGMu2ep8IEisxwyUQfFqLr7u+Exv7MBqtinYdTgFs1C6RuPJUJoEDKDLQAgd6tz3Joe O5UObhunwfkEj1r8hLQofHr0ohyq8aaCGwAe2QP6pJaIAaLhouo2Otwq/e/KnHL7Xt77D6HYKFyr8 ep3MBAVnRld4dBVN0InxOa1L3IACKFwn2x5nHsxvoxYot5+ECkfOsKGSkL7p/LHs4VLhTL1CE4BoI wk3r0u5WL7FRFWaHJyKp8Ey5ZNOvtdY0/bU9jgCOyuXLEmPbyuobGMXFHbUwjDKv8LD0OAjlqY7eZ Ai1YUnTg==;
      29: Received: from c11-92.tlh.ro ([86.105.187.92]:59678 helo=localhost)
      
      23: bh=Mfeb2i5EeCiNoEabwwaBRo8bnT4HLAR5z32ZZKIh8oo=; b=Izrj7xp7XVH0efHVJAFKpOIl1Y PNTYKwXkPmlu0QW9CNq0XNha3W1Rf/TD3qNMQxvkbn25G71nOseLQxORPcBItPDp3QJWzi7t8mDUH wccJjVfIvHoq7T+tuhB2vp64g6IMGwQ7XoGXXDreoumLQxv2yk/CwRneEjgO3fuBJbtnSggVMVWM0 RY7I8rMgIvHUeveZxjcL+DMKP1k7cHXTFrQj/0jnFqnjMFw3FNKt5QOSZMG2/Wem3I/V5VzOI2iEV aAXtbxdhkI94nuRueQ3b2UndL6MpQVjK+nS4dwfp9KPYU+pAXVusvreLloSAhSw+kcWgsUBMmyIe8 AcxxJoxQ==;
      29: Received: from c11-92.tlh.ro ([86.105.187.92]:59460 helo=localhost)
      
      
      32:     id 1bB7BJ-0005mx-Vc; Fri, 10 Jun 2016 00:08:02 +0300
      32:     id 1bB7Ah-0005mG-EH; Fri, 10 Jun 2016 00:07:23 +0300
      

It seems that it is creating two separate emails with different ID's for some reason. I am struggling with this for over a week now and I just can't find out what is wrong.

  • Just a quick update: checking the SMTP Pro logs, I found that there are two emails created for the customer and one that is sent to the store owner. Can anyone please give me a how to trace step-by-step the email creation procedure? – Andras Jun 12 '16 at 11:47
  • Here is the cause of the problem: one email is sent with cron and the other is sent directly. How can I disable the direct sending and only use the cron? – Andras Jun 12 '16 at 17:35
0

I am not sure there is an option for this. I had the same problem. It was caused by diverged php-fpm and php-cli configurations. PHP-FPM had Memcached as a caching backend activated and the memcached extension enabled. PHP-CLI had the same caching backend activated but had no memcached extension, which caused Magento to fall back to the File cache backend. I am not 100% sure why this happens, but I think the cache is somehow involved in the email sending process.

Maybe check if there is a similar problem with your hoster.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.