0

I added an extension to a new magento 2 digital ocean droplet. But when I run setup upgrade the extension is not added to app\etc\config.php. I've added a folder in app called tomispepe and added a folder in it called checkout.

these are my files: /var/www/html/magento/app/tomispepe/checkout/registration.php DIR );

the module xml is here: /var/www/html/magento/app/tomispepe/checkout/etc/module.xml

that's it.

Then I ran: ./bin/magento cache:flush ./bin/magento setup:upgrade

then this should have included my new extension cat app/etc/config.php | grep tom but it did not!

in my dev env this works but on my droplet it does not. There must be something unique about my droplet. Please help.

1

This assumes that you are adding the module via app/code and not as a dependency via composer.

After adding a module under app/code/, assuming it has at minimum a registration.php file and etc/module.xml file that contain the proper statements(I would recommend taking the skeleton for both from a core module), you will need to enable the module by running:

$ bin/magento module:enable <Vendorname_Modulename>

so if your module should live under app/code/tomispepe/checkout/ then the module name would likely be Tomispepe_Checkout.

Then, after enabling the module, the cli utility will typically recommend running any data and install scripts(there may be none for your module, just run this anyways) via:

$ bin/magento setup:upgrade

At that point you can ensure that your module is enabled by running:

$ bin/magento module:status

Ensure that your module is under the "List of enabled modules". As a side note, app/etc/config.php is modified by the bin/magento cli commands and so you should prefer using the commands over reading the contents of that file.

  • it looks like the OP copied from the correct location on the local machine to the incorrect location on the droplet /var/www/html/magento/app/tomispepe/checkout/ (missing code after app) – Kristof at Fooman Jun 9 '16 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.