I had a Magento2 version 2.0.5 and I upgraded it to Magento 2.1.0rc1 using composer. I ran the command for setup upgrade and db schema upgrade.

After upgrade I have faced some comparability issues with my custom extension so I downgraded it to 2.0.7 using composer. and ran below commands

composer require magento/product-community-edition 2.0.7 --no-update
composer update
rm -rf var/di var/generation
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento indexer:reindex

Now Magento is not working and its giving me error that version of my certain modules in db is different then they are in file system. Any idea what I did wrong and how to get it back ?

1 Answer 1


Had the same problem and Magento2 doesn't support roll-back completely. What you have right now is

Your database is at 2.1.x and your code is 2.0.7.

When you upgraded to 2.1.x than your suppose there were certain new columns added in db (just to give you insight). and when you downgraded the code is at 2.0.7 but database columns are not deleted (assuming a column was created while upgrade, just for explanation.). Now you have a miss match.

What to do :-

If you have a db copy of your magento 2.0.5 than link current app to it and run upgrade. It will bring your 2.0.5 db to 2.0.7 and you will be in sync again.

  • Was doing the same and yes it worked for me.
    – user40778
    Jun 9, 2016 at 7:31

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .