1

I followed @Marius answer here

it worked fine in one site, in another site below error once i go to

System > configuration > Sales > checkout ,

Fatal error: Class 'StackExchange_Checkout_Helper_Data' not found in /var/www/html/sitename/app/Mage.php on line 547

compilation

Compiler Status : Enabled
Compilation State : Compiled

config.xml - app/code/local/StackExchange/Checkout/etc

<?xml version="1.0"?>
<config>
    <modules>
        <StackExchange_Checkout>
            <version>0.0.1</version>
        </StackExchange_Checkout>
    </modules>
    <global>
        <blocks>
            <checkout>
                <rewrite>
                    <onepage>StackExchange_Checkout_Block_Onepage</onepage><!-- rewrite the onepage chackout block -->
                </rewrite>
            </checkout>
        </blocks>
        <helpers>
            <stackexchange_checkout>
                <class>StackExchange_Checkout_Helper</class>
            </stackexchange_checkout>
        </helpers>
        <models>
            <stackexchange_checkout>
                <class>StackExchange_Checkout_Model</class>
            </stackexchange_checkout>
        </models>
    </global>
    <default>
        <checkout>
            <options>
                <hide_shipping>1</hide_shipping>
                <default_shipping>tablerate_bestway</default_shipping><!-- set the default shipping method code -->
            </options>
        </checkout>
    </default>
    <frontend>
        <routers>
            <checkout>
                <args>
                    <modules>
                        <StackExchange_Checkout before="Mage_Checkout">StackExchange_Checkout</StackExchange_Checkout>
                    </modules>
                </args>
            </checkout>
        </routers>
        <translate>
            <modules>
                <StackExchange_Checkout>
                    <files>
                        <default>StackExchange_Checkout.csv</default>
                    </files>
                </StackExchange_Checkout>
            </modules>
        </translate>
    </frontend>
</config>
6
  • post your config.xml too Commented Jun 9, 2016 at 7:31
  • do you have compilation on or off?
    – Marius
    Commented Jun 9, 2016 at 7:32
  • @QaisarSatti updated the question. Commented Jun 9, 2016 at 7:35
  • @Marius updated the question. Commented Jun 9, 2016 at 7:35
  • Disable the compilation and try again
    – Marius
    Commented Jun 9, 2016 at 7:37

2 Answers 2

4

In case you have the compiler on, you need to disable it each time you add a new extension. You can enable it after that again.

1
  • 1
    i am an idiot, did't followed standard procedure to install. Thanks. Commented Jun 9, 2016 at 9:13
1

Ensure app/code/local/StackExchange/Checkout/Helper/Data.php exists in the right location.

And ensure the class name is correct StackExchange_Checkout_Helper_Data

Both file location and class name must be case sensitive

9
  • Thanks, cross checked it, file in right path & class name is also correct. Commented Jun 9, 2016 at 7:00
  • Does your configure XML define stackexchange as a helper alias?
    – scrowler
    Commented Jun 9, 2016 at 7:05
  • @RobbieAverill can you guide me path of configure XML file Commented Jun 9, 2016 at 7:07
  • Config.xml in your modules etc folder
    – scrowler
    Commented Jun 9, 2016 at 7:08
  • 1
    @RaphaelatDigitalPianism sorry for delay, it worked fine after i recompiled. Commented Jun 9, 2016 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.