0

So I'm using a customer tracking extension and after adding the files to the server, I receive an HTTP Error 500 when trying to access the System Configuration page of my admin panel. I'm having issues targeting the exact problem. Sometimes when the system.xml file of the extension is on the server, I can access System Configuration, and other times I can't. When it does let me (and the system.xml file is on the server), the Customer Tracker options are there on the left panel. However, when clicking them, I get the error again. So, I figure the issue has to be within the index.phtml or system.xml, config.xml, admin.html.

<?xml version="1.0"?>
 <config>
  <tabs>
    <pixelmarket translate="label" module="pixel">
        <label>Customer Track</label>
        <sort_order>0</sort_order>
    </pixelmarket>
  </tabs>
  <sections>
    <kssec  translate="label" module="pixel">
    <label>Customer Tracker</label>
    <tab>pixelmarket</tab>
    <frontend_type>text</frontend_type>
    <sort_order>0</sort_order>
    <show_in_default>1</show_in_default>
    <show_in_website>1</show_in_website>
    <show_in_store>1</show_in_store>
                <groups>
                  <ksgroup translate="label">
                  <label>Configuration</label>
                  <frontend_type>text</frontend_type>
                  <sort_order>0</sort_order>
                  <show_in_default>1</show_in_default>
                  <show_in_website>1</show_in_website>
                  <show_in_store>1</show_in_store>
                   <fields>
                      <enable translate="label">
                        <label>Enable</label>
                        <frontend_type>select</frontend_type>
                        <source_model>adminhtml/system_config_source_yesno</source_model>
                        <sort_order>0</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                        <comment>Activate this plugin</comment>
                      </enable>

                      <type translate="label">
                        <label>Tracking Type</label>
                        <frontend_type>select</frontend_type>
                        <source_model>adminhtml/system_config_source_tracktype</source_model>
                        <sort_order>1</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                      </type>

                       <start_date translate="label">
                        <label>Start Date</label>
                        <frontend_type>text</frontend_type>
                        <frontend_model>pixel/adminhtml_system_config_date</frontend_model>
                        <sort_order>2</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                      </start_date>

                      <end_date translate="label">
                        <label>End Date</label>
                        <frontend_type>text</frontend_type>
                        <frontend_model>pixel/adminhtml_system_config_date</frontend_model>
                        <sort_order>3</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                      </end_date>

                   </fields>
                   </ksgroup>
                </groups>
    </kssec>
  </sections>
</config>

Now, I've made some changes to all the files in the extension and everything is consistent throughout them.

If anyone thinks I need the config.xml too, I can post it as well.

Found this in frontend/.../template/pixel/index.phtml file:

$enable = Mage::getStoreConfig('kssec/ksgroup/enable');
$tipe = Mage::getStoreConfig('kssec/ksgroup/tipe');
$mulai = Mage::getStoreConfig('kssec/ksgroup/start_date');
$selesai = Mage::getStoreConfig('kssec/ksgroup/end_date');

Using information from this: https://stackoverflow.com/questions/5892476/how-to-get-data-from-magento-system-configuration I checked the core_config_data table and found nothing with kssec/ksgroup/.. Also, the "tipe" that a commenter thought was a misspelled "type" is also derived from here as seen above.

So if anybody can help further, it would be great. I changed "type" back to "tipe". The System Configuration page in admin panel loads, and the Customer Track option in the left panel is there, but clicking Customer Tracker brings up the HTTP Error 500 still.

  • You're missing the closing </config> tag in system.xml – Robbie Averill Jun 8 '16 at 0:36
  • Sorry, it's only missing in my original post. It's actually there in the real file. – taskle Jun 8 '16 at 1:09
  • that's OK, just edit your question and replace your code with an accurate example. – Robbie Averill Jun 8 '16 at 9:14
1

I noticed "adminhtml/system_config_source_tracktype" source model is set for "tipe" field and obviously this class is not a part of the default Magento package. Please check if you have got an app/code/.../Mage/Adminhtml/Model/System/Config/Source/Tracktype.php" in any of the code pools, i.e. core, local or community.

I assume you have the needed class in the "pixel" module, so please check if there is a Pixel/Model/Adminhtml/.../Tracktype.php

  • I fixed the tipe -> type, and it has gotten me to be able to at least load the System Configuration page in my admin panel. However, by clicking the Customer Track option from the list on the left, it will still give the error. I do have the Tracktype.php in app/code/core/Mage/Adminhtml/Model/System/Config/Source/ There is no AdminHtml directory within Pixel/Model but Pixel/Block/Adminhtml/System/Config and only contains Date.php – taskle Jun 8 '16 at 12:02
  • I forgot to add that I added Tracktype.php to Pixel/Model/Adminhtml/System/Config/Source directory as well – taskle Jun 12 '16 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.