1

I've been following this tutorial to add currency switcher to header of my magento theme: http://www.jimcode.org/2011/02/magento-multi-language-currency-region-setup/

I've add currency block and others under header of my page.xml file:

<block type="page/html_header" name="header" as="header">
    <block type="page/switch" name="store_switcher" as="store_switcher" template="page/switch/stores.phtml"/>
    <block type="page/switch" name="store_language" as="store_language" template="page/switch/languages.phtml"/>
    <block type="directory/currency" name="currency" as="currency" template="directory/currency.phtml"/>
</block>

then under header.phtml file under my template, I've added these lines:

         <div class="span2 offset1 flags-wrapper">
            <?php echo $this->getChildHtml('store_language') ?>
          </div>

          <div class="span1 f-select-wrapper">
              <?php echo $this->getChildHtml('currency'); ?>
              <?php echo $this->getChildHtml('store_switcher') ?>
          </div>

Store language is appearing fine, while neither store views, nor currency views are displaying on the header.

Please help me point out what am i missing.

  • Just to make sure you covered this: Do you have at least 2 currencies and at least 2 store views enabled on your website? – Marius Dec 17 '13 at 8:07
  • Yes this is what I was missing. I've added 2-3 currencies using this tutorial, and it worked like a charm: inchoo.net/ecommerce/magento/… If you could add this suggestion, as an answer rather than comment, I'll mark that as correct. Thanks – anwartheravian Dec 17 '13 at 8:49
2

The currency switcher appears only if you have at least 2 currencies enabled.
Same goes for language/store view switcher. It appears only if you have at least 2 active store views on your website.

  • I have two languages and 2 currencies setup. The home page only has language selector showed up, not the currency selector – Michael Z Mar 28 '15 at 1:16
  • I have same issue ...u got solution? – Ram Pratap Singh Gour Jan 29 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.