2

I have a problem with the auto-generation of my sitemap. I did everything I have written below.

  1. I created a sitemap through Admin > Catalog > Google Sitemap option
  2. I made the auto-generation setup Admin > System > Configuration > Catalog > Google Sitemap > Generation Settings
  3. I added crontab a cron job for cron.sh (This cron job runs every hour / I have evidence that it works)

But the auto-generation still does not work! Is there any log files I can check? I don't know what's missing!

  • Have you set your sitemap to generate every hour? Usually it's once a day. Can you add your screenshot? – Adarsh Khatri Jun 6 '16 at 14:01
  • Magento's cron.sh runs every hour. The setup for the sitemap.xml is once a day at 00:05. – J.Corby Jun 6 '16 at 14:03
  • You have to wait till next day then. Or is it you have already waited 1 day. – Adarsh Khatri Jun 6 '16 at 14:05
  • Yes I did. The sitemap.xml job setup is for 00:05. But I created a sitemap through Admin > Catalog > Google Sitemap option in the daytime manually / by hand. – J.Corby Jun 6 '16 at 14:08
2

Try using n98 to view the cron history and confirm its not being missed , you can also use it to run the manually and confirm it works - https://github.com/netz98/n98-magerun

And change the cron.sh to run every minute or at least every 5.

  • I changed the cron.sh schedule to every 5 minutes. Cron job started to generate the sitemap.xml. Thanks for the advice... – J.Corby Jun 6 '16 at 18:31
  • glad that worked usually you want to do it every minute with cron.sh, as it will check to see if cron.php is still running and do nothing if it is, so that way nothing is missed. – MartyS Magemojo Support Jun 7 '16 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.