0

Someone please help me out, i am new to magento. I have migrated my website to a new server and stuck with this error for days. I use Magento ver. 1.4.1.1 and almost have 1000 products.

Product Prices, Product Flat Data and Category Flat Data are showing PROCESSING for almost 10days in magento panel. When i try to reindex in magento panel i am receiving Cannot initialize the indexer process error

I also tried using ssh for reindexing and i received the following error

[root@vps-#### shell]# php indexer.php reindexall
Product Attributes index was rebuilt successfully
Product Prices index process unknown error:
exception 'Zend_Db_Statement_Exception' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'date' in 'field list'' in /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Statement/Pdo.php:234
Stack trace:
#0 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array)
#1 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Adapter/Abstract.php(468): Zend_Db_Statement->execute(Array)
#2 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('INSERT INTO `ca...', Array)
#3 /var/www/vhosts/mydomain/httpdocs/lib/Varien/Db/Adapter/Pdo/Mysql.php (333): Zend_Db_Adapter_Pdo_Abstract->query('INSERT INTO `ca...', Array)
#4 /var/www/vhosts/mydomain/httpdocs/lib/Varien/Db/Adapter/Pdo/Mysql.php (1537): Varien_Db_Adapter_Pdo_Mysql->query('INSERT INTO `ca...', Array)
#5 /var/www/vhosts/mydomain/httpdocs/lib/Varien/Db/Adapter/Pdo/Mysql.php (1487): Varien_Db_Adapter_Pdo_Mysql->insertArray('catalog_product...', Array, Array)
#6 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price.php(527): Varien_Db_Adapter_Pdo_Mysql->i nsertMultiple('catalog_product...', Array)
#7 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Indexer/Price.php(369): Mage_Catalog_Model_Resource_Ea v_Mysql4_Product_Indexer_Price->_prepareWebsiteDateTable()
#8 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Index/Model/Indexer/Abstract.php(125): Mage_Catalog_Model_Resource_Eav_Mysql4_Product_Indexer_Price->reindexAll()
#9 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Index/Model/Process.php(139): Mage_Index_Model_Indexer_Abstract->reindexAll()
#10 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Index/Model/Process.php(167): Mage_Index_Model_Process->reindexAll()
#11 /var/www/vhosts/mydomain/httpdocs/shell/indexer.php(158): Mage_Index_Model_Process->reindexEverything()
#12 /var/www/vhosts/mydomain/httpdocs/shell/indexer.php(198): Mage_Shell_Compiler->run()
#13 {main}
Catalog URL Rewrites index was rebuilt successfully
PHP Fatal error:  Call to a member function setAttribute() on a non-object in /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php on line 374

This is the error i am receiving in my website

There has been an error processing your request
SQLSTATE[42S02]: Base table or view not found: 1146 Table 'admin_db.catalog_category_flat_store_1' doesn't exist

Trace:
#0 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Statement.php(300): Zend_Db_Statement_Pdo->_execute(Array)
#1 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Adapter/Abstract.php(468): Zend_Db_Statement->execute(Array)
#2 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SELECT `catalog...', Array)
#3 /var/www/vhosts/mydomain/httpdocs/lib/Varien/Db/Adapter/Pdo/Mysql.php(333): Zend_Db_Adapter_Pdo_Abstract->query('SELECT `catalog...', Array)
#4 /var/www/vhosts/mydomain/httpdocs/lib/Zend/Db/Adapter/Abstract.php(725): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select), Array)
#5 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(352): Zend_Db_Adapter_Abstract->fetchRow(Object(Varien_Db_Select))
#6 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Model/Abstract.php(225): Mage_Core_Model_Mysql4_Abstract->load(Object(Mage_Catalog_Model_Category), 23, NULL)
#7 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Catalog/controllers/CategoryController.php(51): Mage_Core_Model_Abstract->load(23)
#8 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Catalog/controllers/CategoryController.php(73): Mage_Catalog_CategoryController->_initCatagory()
#9 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Catalog_CategoryController->viewAction()
#10 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(254): Mage_Core_Controller_Varien_Action->dispatch('view')
#11 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(177): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#12 /var/www/vhosts/mydomain/httpdocs/app/code/core/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#13 /var/www/vhosts/mydomain/httpdocs/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#14 /var/www/vhosts/mydomain/httpdocs/index.php(77): Mage::run('', 'store')
#15 {main}
0

I had similar problems with 1.6, but this worked for me:

Go into the database and find the table index_process_event and delete all of the entries there.

Then go into the file system and from your magento directory, go into var/locks and delete any lock files there may be.

Now when you go back into the admin panel, you should no longer see any "Processing" and you can start reindexing again.

When you do start reindexing, keep an eye on the magento error logs and the system's PHP error logs. You might be running into an issue where PHP can't allocate enough memory, causing the index to fail, which leaves it in a "Processing" state.

If you are still getting errors like "column not found" you might need to repair your database. Be sure to backup your existing database, even if it isn't working, it still contains valuable data you don't want to lose.

Here are the instructions for using the database repair tool : (as of time of writing) http://docs.magento.com/m1/ce/user_guide/magento/database-repair-tool.html

  • This should work in a correctly working environment when the index is failing, but in this case it seems more like a MySQL error than an indexing problem. – Niels Jun 6 '16 at 14:18
  • True, I will also suggest the database repair tool. – David Wilkins Jun 6 '16 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.