1

Site is skydivenow.co.uk Magento 1.9.2.4

Attempting to log in as a customer on the log in page simply re-directs the user to the same page rather than logging them in. I had to turn checkout as a guest back on to provide a work around (but it's not a fix)

Entering either duff info or correct info for login and password both do the same thing - redirect to same page

I have the line

<?php echo $this->getBlockHtml('formkey'); ?>

added to the /app/design/frontend/base/default/template/customer/form/login.phtml however that hasn't cleared the problem (Cache flushed, cookies emptied, tried on Chrome and Firefox)

  • Cookies set to
  • Cookie Lifetime 86400
  • Cookie Path /
  • Cookie Domain .skydivenow.co.uk
  • Use HTTP Only = No
  • Cookie Restriction Mode = No

Website uses SSL and redirects the unsecured base URL to; https://skydivenow.co.uk/ via the Magento System->configuration->Web in the backend. This seemed to fix some other issues and disabling it doesn't seem to help with the login fault, however I'm not sure this is the correct method and may be a root cause along with something else.

I'm sure it is some form of cookie or redirect since the SSL has been introduced but i'm unable to locate what is the actual cause.

  • remove dot(.) from .skydivenow.co.uk. – Amit Bera Jun 6 '16 at 10:14
  • see in db config table. also you need clear cache. – James M Apr 8 '17 at 8:36
0
  • Further, try disabling or removing your popup Login module. That might be interrupting magento's own login procedure. – Ahsan Horani Jun 6 '16 at 10:34
1

Probably you have some issue with Sessions. Here is what happened on customer login: https://monosnap.com/file/RsKVhtWOWCp5BVu6yeT1RIOsPHqzEy

1) customer submit login form

2) redirected to account dashboard

3) lost session and redirected back to login

Maybe it's related on server space or var/session folder permissions (if you are using default (files) session storage)

Or, maybe some custom code destroy session of customer.

More info can be found at Magento logs (var/log/ folder) if you will enable them at Admin - System - Configuration - Developer.

  • I have flushed redis session and magento session but still I am having same issue – groy Apr 9 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.