0

Magento Core: 1.9.2.4
Theme: Milano - Fashion Responsive Magento Theme

I have added a few extra custom strings in /app/design/frontend/alomilano/home02_fashion/template/catalog/product/view/addto.phtml
like this:

<?php echo Mage::helper('catalog')->__('need help?') ?>  

also tried like this:

<?php echo $this->__('need help?') ?>

and added the strings in /app/locale/en_US/Mage_Catalog.csv & /app/locale/el_GR/Mage_Catalog.csv like this:

"need help?","need help?" (en_US)
"need help?","χρειάζεσαι βοήθεια;" (el_GR)

The translation in Greek (el_GR) works perfect, but when I switch to the English website (en_US) it still shows me the Greek translation!

I have clear ALL caches (many times).

What am I doing wrong?

0

Try to use inline translation.

Go to

System > Configuration > ADVANCED > Developer

Find section Translate Inline and Enable it (Frontend/Backend)

Then go to page that you want to translate and click on text that you want to translate. Translate pop-up will open.

0

Instead of /app/locale/en_US/Mage_Catalog.csv go to your app/design/theme_vendor/theme_name/locale/en_US/translate.csv and add your translations here. Use the same for another language you have.

Note: theme_vendor/theme_name is alike base/default or default/modern

Not the answer you're looking for? Browse other questions tagged or ask your own question.