I search on google but not getting any proper solution. Does anyone has any solution for this ? I am getting this error from admin panel while readiness check for upgrade magento 2.0.7 version.

enter image description here

  • How did you perform the update (update steps)? Commented Jun 2, 2016 at 5:23
  • I entered public key and private key then go to system > web setup wizard > system upgrade then check for readiness and throw error which is mentioned in image Commented Jun 2, 2016 at 18:11
  • Those type of problems are most probably related to a not correct configuration of the server. Click in show details and try to post here or search with google those types of problems. Commented Jun 5, 2016 at 12:19
  • When I update my version of magento I use always composer, like shown here magento.stackexchange.com/questions/98332/… . But not remove vendor folder rename it, so you can eventually use it again. Make a copy also of your composer.json for security. Commented Jun 5, 2016 at 12:21
  • i changed image plz check question Commented Jun 5, 2016 at 12:38

2 Answers 2


The error is quite user friendly and is saying to set cron job on server. Set below to execute after every 5 minutes on server

php yourMagentoPath/bin/magento cron:run

And perform the check again.

[Cause] :- To upgrade Magento it is must to set a cron job unless you are upgrading using composer. There are many other rediness checks that will only be performed once this cron is set. Try this once and share if it worked.

Apart from this the better way to upgrade Magento is to use composer. Its easy to upgrade using this method and it take less time(Never run composer as root user). By using this method roll-back is also very easy just make sure you have backup of your database as check this issue.


follow this steps

  1. php version must be below

    PHP 7.0.2–7.0.6 except for 7.0.5, 5.6.x or 5.5.x (PHP 5.4 is not supported)

  2. please ask to your service provider that in apache modules rewrite_module is enabled or not? if not than please enable it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.