0
Forbidden you don't have permission to access /Magento/pub/static/frontend/Magento/luma/en_US/Magento Ui/templates/modal/modal-popup.html on this server.

Don't know why I am getting this error on magento fresh site.

enter image description here

2
  • 1
    the error is obvious and there are already a lot of questions about fixing permission errors in mage2 Jun 1 '16 at 21:14
  • instead of downgrading the question please try to give links also to the proper answers or exact question.
    – khan
    Jun 1 '16 at 22:50
2

You needs to set the correct permission on your server.

See here: Magento 2 Pub/Static Correct File Permissions

7
  • I know this too but if i knew how to set permission then why would i ask here. the link you provide does not really answer the question.
    – khan
    Jun 1 '16 at 22:48
  • depending on what kind of os your server is, will determine how you will reset those file permission.
    – Aedonis
    Jun 1 '16 at 22:50
  • magento.stackexchange.com/questions/91870/… . If you need a more detailed answer.
    – Aedonis
    Jun 1 '16 at 22:52
  • Mac osx yosemite 10.10.5 and i am using MAMP. Thanks
    – khan
    Jun 1 '16 at 22:52
  • Then you will need to look for the commands to change the file permissions for the /pub/static folder and files in the folder that work with MAMP. The solution in the links i added above should help you to figure out which folders to change and to what.
    – Aedonis
    Jun 1 '16 at 22:54
0

I've had this problem before in MAMP. You have to try to change the system file permissions for the folders, but also the file permissions for the server.

In Windows I fix a lot of my problems simply by running as administrator but there isn't really an equivalent on Mac

0

Solved Finally!!!!! i am using mac Yosemite 10.10.5 its easy.

step1:

goto root folder of magento like this:

cd Applications/MAMP/htdocs/Magento

step2:

and then one by one type these

php bin/magento setup:static-content:deploy

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento cache:clean

and you are done!

if you receive fatal error about Local missing in some php bundle bla bla bla ... in php bin/magento setup:static-content:deploy step2. Its because your php is 5.5 or other version than the one running on MAMP. Which you can check by this command

php -i its running on mac

and php running on MAMP: http://localhost:8888/MAMP/index.php?page=phpinfo&language=English

if both are same then you have to find anather solution or make php to the one supported by magento.

if both are not the same you have to change your "mac php" path to "php inside MAMP" folder. todo that: write in terminal

vim ~/.bash_profile

new VIM terminal window will be open then type i and past this path or the correct one(in my case its this one):

export PATH=/Applications/MAMP/bin/php/php7.0.0/bin:$PATH

to exit VIM and go back to terminal: esc and then wq or Shift+zz

then in terminal type

source ~/.bash_profile

and then come back here to cheers!!!(its important :))

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.