4

i am using MAMP on Mac OSX Yasmite 10.10.5 and getting this error.

SQLSTATE[HY000] [1045] Access denied for user 'root'@'localhost' (using password: NO)

enter image description here

I have created database and name it magento.

enter image description here

enter image description here

Don't know where is the problem + there is no local.xml in magento/app/etc instead di.xml is available. Thanks in advance for any help.

4

Your server host is localhost:8889

So on the Database Server host try to give localhost:8889 instead of on localhost.

Hope this will help you

4

Solved! i was missing the password and it was 'root' check in your phpmyadmin. Then i was asked for the mysql update because magento require 5.6 or above so this link helped me.

http://blog-en.mamp.info/2015/07/how-to-use-mysql-5-6-with-mamp-and-mamp.html

until step 2 you will be fine with magento.

1

I faced similar issue with Magento 2.0.7 installation.I was using root user without password so I got this issue.

After assigning a password to the root user(Do not forget to restart mysql server) and retrying to install solved the issue.

2
  • There shouldn't be any need to restart MySQL after changing a password.
    – scrowler
    Jun 11 '16 at 22:56
  • @RobbieAverill You may be right but in my case. I was able to proceed after restart only.
    – Mukesh
    Jun 12 '16 at 17:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.