0

When I issue this command on bash shell (Copied directly from this here):

composer config repositories.data-migration-tool git https://github.com/magento/data-migration-tool

I get the following error

"File "composer.json" cannot be found in the current directory"

I've included the path of composer.json in the $PATH but still get the above error

I am migrating from Magento 1.9.0.2 to a clean install of Magento 2.0.7 from a bitnami AWS AMI Ubuntu 14.x server. Running the command on Mac OS X. I've updated composer.

0

I would try the command from the root of your Magento install to make sure that your $PATH isn't the issue. If that still doesn't work, I would check to make sure that the ownership and permissions on the composer.json are correct. It could be that its there and you are hitting it, but your user doesn't have rights to the file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.