9

I am developing a site on a local server using developer mode (in env.php) I enable the checkout to the payment page, however, despite setting up all payment methods (individually as well to test for any conflicts) it is showing as No Payment Methods

I have Enabled all Methods.

Can anyone shed any light?

  • have you enable payment method from backend (Admin) ? – Bilal Usean May 26 '16 at 12:42
  • I have gone to Stores>Configuration> Checkout section selected all the payment gateways and enabled them. Is there anywhere else? – PHPDev76 May 26 '16 at 12:56
  • check Payment from Applicable Countries and Payment from Specific Countries Settings for payment as well – Minesh Patel Feb 10 '17 at 12:48
  • Did you manage to solve this? I am having the same problem. Klarna is not showing as a payment option on checkout. – user3091199 Mar 26 at 8:17
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Vivek Kumar Mar 26 at 8:46
18

Have you override the file checkout_index_index.xml ? If, yes, make sure you have created your custom checkout_index_index.xml in the right folder like : design/frontend/NameSpace/your_theme/Magento_Checkout/layout/override/base/checkout_index_index.xml

http://devdocs.magento.com/guides/v2.1/frontend-dev-guide/layouts/layout-override.html

Hope it help

  • Worked perfectly +1 – tim.baker Jun 12 '17 at 21:27
  • This mush be the accepted answer :-) Saved a day – Butterfly Jun 8 at 13:32
0

Clear your cache and maybe upgrade and compile your code.

php bin/magento setup:upgrade

php bin/magento setup:di:compile

Navigate to your Magento folder in your Terminal and run commands if your PHP versions aren't the same will see an error.

In this case you will create an alias that has the path to the MAMP PHP file

alias phpmamp=/Applications/MAMP/bin/php/php5.6.27/bin/php

Then run commands above with phpmamp instead of php

NOTE: alias will chance based on path and what version of php you are using

0

For the sake of testing, toggle the Enable Onepage Checkout in Config > Sales > Checkout to see if the payment methods show up on the two-step checkout.

In my case, the toggle got flipped so that, although Enable Onepage Checkout was set to No, I was getting the One Page Checkout view on the frontend. After flipping the setting, I was able to see all the correct Payment Methods on the second step of the checkout process (as expected).

I'm not exactly sure "how" my checkout toggle got flipped (yes is now no) but I suspect it had something to do with PayPal config settings.

Once your Payment Methods show up then you can start troubleshooting why they don't appear on the One Page Checkout.

-1

Please check design/frontend/NameSpace/your_theme/Magento_Checkout/layout/override/base/checkout_index_index.xml file in theme folder or use default checkout_index_index.xml file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.