0

I was getting a white screen on my store, so i was trying to debug the error and it was showing this error. Anyone knows how to fix it?

    Array
(
    [type] => 2
    [message] => vsprintf() [function.vsprintf]: Too few arguments
    [file] => /home/vhosts/MYSITE/subdomains/test/httpdocs/app/code/core/Mage/Core/Model/Translate.php
    [line] => 416
)

1 Answer 1

0

This happens if a translation requires variables (printf syntax, usually %s or %d) but they are not provided.

Trace the error and watch out for __('something %s something') - it should be __('something %s something', 'something')

8
  • There are no % in translate.php. Could u give us some advice? Commented May 25, 2016 at 9:18
  • Translate.php is not the source of the error. Don't you see a stack trace? Commented May 25, 2016 at 9:21
  • We where fixing a other error first. This one: Fatal error: Call to a member function getBackend() on a non-object in /home/vhosts/MYSITE/httpdocs/includes/src/Mage_Eav_Model_Entity_Collection_Abstract.php on line 514 But someone said that was a module error so i needed to uninstall every costum module one by one., but we accidentally deleted Mage_core Commented May 25, 2016 at 9:27
  • That was bad advice. This error message is usually the result of an uninstalled module that is still referenced in a product attribute. But I don't see how this is related to the question? Commented May 25, 2016 at 9:40
  • Because when we deleted mage core. We got this error and a blank sceen on every page. And after we deleted all the products we still get the error with the abstract. Commented May 25, 2016 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.