4

I am trying to Import customers with their names in Japanese(katakana). It shows following error in validation results (On linux machine)

Required attribute 'firstname' has an empty value in rows: 1,2,3,and so on

The values are there in the column for firstname, but still it says empty value. If I enter English characters instead of Japanese, it accepts and does not show any error.

If I do the same thing on Windows OS, same file with Japanese characters works perfectly.

Not sure, if its a Magento's bug or I need to do something differently?

If anyone has a solution or any suggestion, please let me know

File format is .csv, Encoding utf-8

The contents of the file are:

email,_website,_store,firstname,lastname,password_hash,created_in,store_id,group_id,website_id,prefix,middlename,suffix,dob,taxvat,confirmation,gender,created_at,rp_token,rp_token_created_at,disable_auto_group_change,password,_address_firstname,_address_lastname,_address_country_id,_address_region,_address_postcode,_address_city,_address_street,_address_telephone,_address_fax,_address_company,_address_prefix,_address_middlename,_address_suffix,_address_vat_id,_address_default_billing_,_address_default_shipping_
john.doe@example.com,base,default,金魚,金魚,2049484a4020ed15d0e4238db22977d5:eg,,1,1,1,,,,,,,,"2007-08-31 00:23:13",,,0,,,,,,,,,,,,,,,,,
  • Can you provide the first few lines of the file, just mix the letters to be ensure privacy. I have no clue of japanese, but your customer's customer's should be safe. – Fabian Blechschmidt Dec 10 '13 at 9:26
  • 1
    would be great if you can edit it into your question with the header :) – Fabian Blechschmidt Dec 10 '13 at 9:37
  • yea, let's dig into this... – Fabian Blechschmidt Dec 10 '13 at 10:21
  • Sorry :-) File is valid! To start import process press "Import" button Import – Fabian Blechschmidt Dec 10 '13 at 10:26
  • 1
    Seems like an encoding issue. Stepping through the code, where does it die out? – benmarks Jan 9 '14 at 12:26
1

I can say for sure that this is an encoding problem (as most of the people suspect in the comments).
I tried with the sample provided in the question on Windows (PHP 5.3) and it works.
I tried on linux with PHP 5.3 and it works.

The encoding for the file I used is UTF-8 Without BOM.
Maybe that's what you need.

  • Thanks for replying. The csv file encoding is UTF-8 without BOM (since I use notepad++, I could see it). Actually, the same file which works on local system(windows) does not work on server(linux) is a big problem. Maybe some server settings, i guess. – Raks Feb 25 '14 at 9:13
  • 1
    @Win8_learner. Like I said, it worked for me on linux. So I guess you might be on to something. Check the server settings. Unfortunately I don't have any ideas on where you can start on this. :( – Marius Feb 25 '14 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.