2

I am having real trouble getting past this stage. I have looked at posts on this topic from different websites and none of the solutions work. I have created secret keys via magentocommerce website and using the keys to login to repo.magento.com.

Everytime I get the same error:

[Composer\Downloader\TransportException]
Invalid credentials for 'https://repo.magento.com/packages.json', aborting.

I have tried the manual approach when the username and password keys are not stored in auth.json file in .composer. After I enter the username I see the following error:

Password: bash: stty: command not found

I then tried to add the username and password to auth.json using the following format suggested here getcomposer.org/doc/articles/http-basic-authentication.md

I then ran this to test:

/usr/local/php56/bin/php-cli composer.phar update --dry-run

Which results with:

Loading composer repositories with package information

[Composer\Downloader\TransportException]
Invalid credentials for 'https://repo.magento.com/packages.json', aborting.

I have also created and new magento account and created new set of keys which has not helped.

Is anyone able to help?

Kind regards,

Hemal

1 Answer 1

3

The repository is not available right now, Magento is aware, it should be fixed soon:

verification on twitter

3
  • Don't heard anything from Magento official channel. I thought my Enterprise key had trouble. May 22, 2016 at 12:50
  • (answered as CW to add the screenshot, can be deleted when downtime is over) May 22, 2016 at 12:50
  • before this twitter post from @MagentoDevDocs, I think there wasn't any official statement about this. It seems that Magento weren't aware of the problem before. There is also an older thread on the forum getting back to life: community.magento.com/t5/Just-Ask-Alan/… May 22, 2016 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.