1

I have a multistore and have just added a new store and gone to upload the new products as I usually do however this time the upload won't work with new SKUs.

I already had about 5 products in the new site to test and using their SKUs only the upload works? But if I add another line and change the SKU it gives an error 'attribute set does not exist'for the last line which of course it does as the lines above have the exact same set and no error!

On working through this I found that its the new SKU that stops the upload. Can Magento stop new products from uploading?

Any help or advice would be great.

I have already tried using open office, notepad, and saved as UT8, MSDOS CSV, took off all but required fields and still the same. I also added a new product in the backend and added it to the upload file which worked... but not when I add a new product in the csv file and try to upload.

0

Must be missing a field that is required.

That's the only time it would reject the file, because it tries to look up the SKU, can't be found, so row fails to import.

| improve this answer | |
  • OK thanks for the reply and suggestion, I'll check through all the fields of a product, we do have some new attributes added through a plugin which are in the file but some may be missing. – Keith May 20 '16 at 11:35
  • Any luck finding the missing attributes? – elfling May 25 '16 at 8:24
  • No Luck yet, I have tried this with a simple_export_example off the web and then tried to upload to 2 sites on 2 different servers with different plugins and am getting same result when trying to add a new sku? – Keith May 31 '16 at 9:33
  • 1
    As an update: If I leave one row filled in with an existing product and sku, the upload works perfect, if I then copy that line and paste it into another row and change the sku, it gives an error that the product type is not supported? – Keith May 31 '16 at 10:11
  • @Keith: I'm having the same exact issue. Did you resolve it? – Protector one Jul 1 '17 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.