0

Don't ask why but my client doesn't want all order emails being send. Is there an easy way to stop this? He wants to send these mails himself. So all automatic outgoing emails (order) needs to be stopped. When there is a new order don't send any email and also on the other order mails after that (status/updates etc).

4
  • Which Magento Version? May 18, 2016 at 8:44
  • Sorry, forgot to mention, I'm on 1.9.1.0
    – Marc
    May 18, 2016 at 8:52
  • Just seeing these settings; I think when setting off (SALES > EMAILS FOR SALES) will also not send email to the store owner when there is a new order? Only the client who orders don't need to get any emails
    – Marc
    May 18, 2016 at 8:56
  • Oh, btw: if you really want to disable ALL emails to customers, there's a setting in System>Configuration>Admin for this May 18, 2016 at 10:42

1 Answer 1

1

I think the most simple way for your version is to install a module like Aoe_Scheduler which allows you to disable specific cron tasks, and disable core_email_queue_send. As far as I know, in 1.9.1.0 the only emails that use this cron task are order confirmations. You should check first to be sure, though.

8
  • Istalled the module. Just to mention; I use this module to send because Magento didn't work out of the box for sending emails: aschroder.com/product/smtppro-magento-smtp-email
    – Marc
    May 18, 2016 at 9:19
  • Should work with it, afaik it only changes the way mails are sent, not then "when" May 18, 2016 at 9:20
  • I just did a test order but got email. I disabled core_email_queue_send_all but it looks like its ignoring it.
    – Marc
    May 18, 2016 at 9:26
  • Hm, ok; maybe it's not working because of the module then. I think you will then have to write a custom module and either listen to an event, or rewrite the order model May 18, 2016 at 9:28
  • I saw this post in the sidebar and think this will work. magento.stackexchange.com/questions/109683/… But as I posted before I'm not sure the site owner gets email when there is a new order. Testing 123
    – Marc
    May 18, 2016 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.