0

I've spent best part of a day trying to upload products to a magento 2 store with little success.

The problem suggests it's a timeout or permissions error, yet i've checked all of these:

  • PHP Execution time
  • Files and folder are set to 755
  • Have tried fetching files from /pub/media/import
  • Have tried fetching files from /var/customfolder
  • Have tried variations of paths above to include /home/domain/public_html/..
  • Have tried leaving the image path field blank
  • Have tried using a complete http://domain/pub/media/import url
  • Have CHMOD all the images in question to 755 to overwrite erroneous permissions
  • Have varied the format of the .csv upload (image url with /beforeimage.jpg)

File upload size is set to 10Mb and the file is 4mb Fresh install of magento 2.0.5 via web setup on php 5.5 apache linux server

The only solutions i've managed to find suggest installing php 7, which i'm informed is a total catastrophe of a build so won't be doing that.

Sure someone's come across the same issue surely?! I'm stumped!

  • refer this link, may be you also did the same mistake magento.stackexchange.com/questions/109135/… – Bilal Usean May 18 '16 at 10:18
  • nope. tried a test csv with more than 10 products. – N.Smith Jun 1 '16 at 15:41
  • Have you verified if the image whose path you entered in your product CSV is existing in pub/media/import folder? Magento2 throws error if the image path mentioned in CSV files are not found at image path. Magento1 used to ignore it but this is not the case here. – Dexter Jun 2 '16 at 4:28
  • @N.Smith not only 10 product is my problem. can you notice in that link the main reason is image path. – Bilal Usean Jun 2 '16 at 4:45
0

I had similar sounding problem with importing product images. In my case the problem was large image files, say 2+MB. I used Photoshop -> Scripts -> Image Processor to batch reduce the images target size/quality for product full zoom.

Providing the exact error message may help get a better answer. Checking Magento logs, PHP logs, and web server logs may also surface the cause.

  • What is the root cause that Magento do not manage large image files ? – Franck Garnier Mar 23 '17 at 14:59
  • Unfortunately, I do not recall the specific cause for my large image issue. I worked around the problem as described in the answer. I sort of remember something about Magento resizing on import if a max pixel dimension was exceeded and choking on excessively large files. I don't think it was a PHP memory setting and maybe something with GD. This report was while working with Magento 2.0 and I've had much fewer problems since the release of 2.1. Sorry, I can't be of more help. – Ian at Xantek Mar 28 '17 at 4:37
  • 1
    Ok, I had the same problem so, the solution : magento.stackexchange.com/questions/144013/… – Franck Garnier Mar 28 '17 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.