2

I'm using magento 2 , and I just synced my store with magento marketplace , so now If I want to enable or disable a module from Web Setup Wizard page , I get this error from the readiness check : PHP Version Check Your PHP version is . The required PHP version is . Hide detail

Download and install PHP from www.php.net using this PHP Documentation.

For additional assistance, contact your hosting provider.

My php version is 5.6 , I have tryed to use also 7 but still get the error and I have also set always_populate_raw_post_data to -1 , but still getting the error.. Does anyone has any ideea how to fix this ?

  • could you please specify the platform (OS) you are running the Magento. – Mohammad Mujassam May 13 '16 at 13:40
  • not very sure about that , but I'm using GoGeek Hosting Package from siteground.. must be some linux I guess.. – alexcr May 13 '16 at 13:45
  • Possibly relevant -- this post refers to a PHP memory limit problem, but could easily refer to a PHP version problem as well: magento-quickies.alanstorm.com/post/152908661755/… – Alan Storm Dec 17 '16 at 19:43
1

To me the problem does not come from your install but from the module you're trying to install.

I'm pretty sure the module provider did not specify the right PHP versions and that's why the PHP check is failing.

Try to contact the module provider to check what versions did they specify when submitting their module to the Magento Marketplace.

  • but when I installed the module I had no problem to do that , why getting the error now when trying to disable it ? – alexcr May 13 '16 at 13:29
1

You need to setup 2 cron jobs. Add update/cron.php and bin/magento setup:cron:run to your crontab, for example

* * * * * /usr/bin/php -c /etc/php5/apache2/php.ini /var/www/magento2/update/cron.php >> /var/www/magento2/var/log/update.cron.log
* * * * * /usr/bin/php -c /etc/php5/apache2/php.ini /var/www/magento2/bin/magento setup:cron:run >> /var/www/magento2/var/log/setup.cron.log

Reference

  • I have already setup the cron jobs , should I update them like this ? /usr/local/php56/bin/php-cli /home/aspirede/public_html/bin/magento cron:run >/dev/null 2>&1 /usr/local/php56/bin/php-cli /home/aspirede/public_html/update/cron.php >/dev/null 2>&1 /usr/local/php56/bin/php-cli /home/aspirede/public_html/bin/magento setup:cron:run >/dev/null 2>&1 /usr/local/php56/bin/php-cli /home/aspirede/public_html/bin/magento indexer:reindex >/dev/null 2>&1 – alexcr May 13 '16 at 14:24
  • Yes, but you need to set up the time intervals on each line. – Maddy May 13 '16 at 15:54
1

I know with some installs running on plesk I had to add

/etc/pki/tls/certs to open_basedir

This can be done via the plesk admin in the application/domain php settings. Perhaps adding this will help with upgrade or others running into readiness check issues.

1

if you are running in Ubuntu(Linux) then, set the Cron job that may get you out of the issue..

blow official documents may help you to solve the issue..

  1. http://devdocs.magento.com/guides/v2.0/comp-mgr/trouble/cman/php-version.html
  2. http://devdocs.magento.com/guides/v2.0/comp-mgr/upgrader/upgrade-readiness.html#compman-readiness-fail

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.