I'm running Magento 2 on MAMP Pro local dev server (mac osx). I have site installed and running fine.

If I try to run following command in site root in terminal, php bin/magento indexer:reindex I get following message:

Magento supports PHP 5.5.0 or later. Please read http://devdocs.magento.com/guides/v1.0/install-gde/system-requirements.html

How do I fix this?

  • Please upgrade your php version. or update your MAMP with latest version that support php 5.5.0or later – Purushotam Sharma May 12 '16 at 17:39

OSX comes with a version of PHP installed, which can break things.

php --ini can tell you if you're running the OSX version of PHP, or the MAMP version of PHP.

You can also do php --info to double check the PHP version you're running.

MAMP comes with several versions of PHP, so you may also need to go into MAMP settings and change to a newer version of PHP.

Also see: https://stackoverflow.com/questions/4145667/how-to-override-the-path-of-php-to-use-the-mamp-path

|improve this answer|||||
  • instructions via link resolved issue. Thank you. – frshjb373 May 12 '16 at 19:26

add a PHP file named as "info.php" an at root directory with phpinfo()

open it through browser www.yourdomain.com/info.php

Here, search by $_ENV['PHPRC'] or PHPRC and get the value of it, in my case it was php:/opt/alt/php72/usr/bin/php-cgi so my final command to clear cache would be /opt/alt/php72/usr/bin/php bin/magento C:C

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.