8

There are customers imported from Magento 1.9.1.0 which are in customer eav customer_entity and related tables. But admin customer grid shows no records. I have also tested adding new customer from the backend, they are added. Those imported customers can login in the frontend. Customer Index Management always shows processing.

enter image description here

I have tried to manually reindex bin/magento indexer:reindex customer_grid.

It doesn't seem to do anything. I don't think setting up cron will help either. However, it is my localhost.

Customer Grid index has been rebuilt successfully in 00:00:00

Your suggestions are highly appreciated.

Thank you in advance

20

Looks like some error happened in the process of re-index and index status left processing. You need to reset it DB.

For example by query:

update indexer_state set status = 'invalid' where status != 'valid';

Then run:

php -f bin/magento indexer:reindex
  • Awesome @KAndy. It worked. As you said, the status was 'working'. I changed it to invalid and rerun the indexer command : bin/magento indexer:reindex customer_grid. Thanks – rbncha May 12 '16 at 14:57
14

Magento 2 not showing customers in backend grid:

Run the below commands for fix

1) php bin/magento indexer:reset customer_grid

2) php bin/magento indexer:reindex customer_grid

Thanks!

  • Thanks Raph and Nithin, but the command you gave doesn't reindex if the status of the index is not "invalid". Meaning reindexing will ignore "valid" and "processing" statuses. These are defined in the indexer table. So the solution of @KAndy works. And the we can do php bin/magento indexer:reindex customer_grid as you suggest. – rbncha Jun 4 '17 at 12:25
6

Best option is to reset and then reindex via CLI

php bin/magento indexer:reset customer_grid
php bin/magento indexer:reindex customer_grid

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.