I have created Tax Rates for every country, in my case I have 4 type of tax rates:

  1. Europe 23%
  2. Europe 13.5%
  3. Europe 9%
  4. Outside EU 0%

For the non EU country I've created a Tax Rule with the Tax Rate "Outside EU" set and other 3 different Tax Rules for the other 3 Tax Rates for every customer group. In this case we are taking in case only the 23% tax rate.

I've this configuration in the Tax calculation settings: enter image description here

The Tax shipment origin is set to an EU country (so 23%) and also the default tax destination is set to an EU country.

The problem that I'm facing is very simple, I'm seeing correctly the product prices when I'm not logged or logged with an address that is in the EU country, supposing that a product price is 85 €. When I'm in a non EU country (so 0% tax rate) I'm seeing the product always with a price of 85 € that is wrong.

What I'm expecting here is that Magento (calculating the shipment origin) calculate the 23% of tax and then, remove it from the product price, so in this case, the product price have to be 69.10 € and not 85 €!

Why the taxes is not removed? I think that what Magento is doing is:

  • You are in a non EU country so 0% of VAT
  • The product price is 85 €
  • Don't apply any tax (but why if the product is including tax!?)
  • Product price is now show as 85 €

This flow is wrong in my opinion and the correct flow must be:

  • You are in a non EU country so 0% of VAT
  • The product price is 85 €
  • The store shipment origin is in an EU country
  • The destination is in a non EU country
  • Remove the 23% of taxes (because the store is located in an EU country)
  • Product price is now show as 69.11 €

Someone can help me with this annoying issue? Is a Magento bug?


  • Which tax class do non logged in users have? Customer group ID 0? Also which tax class do all your products have? Taxable Goods I guess, and taxable goods is attached to every tax rate?
    – seb
    Commented May 10, 2016 at 17:38
  • Non logged in has the "Retail customer" tax but is not important, I mean, the non logged users have to see the VAT price as the default country is in EU country (23%). All products has the "Taxable Goods" tax class id and yes, is attached to every class rate. Commented May 11, 2016 at 7:59
  • If i understand it right then all customers will see the 23% tax as they are in that tax group. Can you try and set the "Catalog Prices : Excluding Tax" ?
    – seb
    Commented May 11, 2016 at 8:03
  • I cant set excluding tax, I need to input the product prices with tax. If I select to use prices without tax (removing the tax from the price of the product) then some precision digits will lost and bad prices appears. Example: 85 € - 23% is 69.10569105691057, Magento will handle and round this mumber as 69.11 € that is wrong, the result is 85.0053 that is 85.01 € (wrong!) Commented May 11, 2016 at 8:12
  • For me the reason is that all products have this tax group and all customer groups also so it will always include the 23% tax. I have worked with an issue like that recently and for me it was resolved by removing the customer group not logged in from the main tax group
    – seb
    Commented May 11, 2016 at 8:17

1 Answer 1


To have everything working review your settings, specially:

  1. Create the tax rates for every country for every rate
  2. Set the prices display as Taxes Included
  3. Ensure that the customer has a default address specified
  4. Be sure to have the Cross Border Trade disabled

I attached a screenshot for a simple tax rule setting, that works as you described (only Us and Uk).

Tax rule settings for Uk and Us

Tax zones and rates

Tax settings

  • amazing!!! worked perfectly! Commented May 11, 2016 at 12:26
  • 1
    But with this setup, if i want to show in fronted prices for guest with a "default TAX"?
    – Simbus82
    Commented Apr 27, 2017 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.