1

Okay, it's a long story, so sit tight.

First, I cannot disable compiler for some reason. I click disable and it refreshes, saying Enabled still. So I used the command line and disabled it, and got the return prompt of

php compiler.php -- state
Compiler Status:          Disabled

But, if I refresh the back-end, it still reads as Enabled

None of my changes are taking effect due to this, and I am at a loss as to where to go from here

I have even tried recompiling from the command line, it says it runs, but same issue, my changes don't actually show in the front-end of the site

Compiler Status:          Enabled
Compilation State:        Compiled
Collected Files Count:    7416
Compiled Scopes Count:    4

If I attempt to recompile from the back-end, it locks up the site and both front and back ends are unable to be accessed

--Edit--

People have claimed this is a duplicate of the "compiler always disabled" thread found here, but my config file does not seem to be the issue

contents of /includes/config.php here:

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

Even with the 2 lines commented out, compiler still stays Enabled, and disabling it just adds another hash to the line for compiler_include_path (I had 3 hashes before deleting them and trying again.), and if there aren't lines commented, it will properly add a hash to the line in question, but still stay Enabled. So again, the problem does not seem to be with Magento updating this line of code.

--Edit 2--

Came in today and saw that the compiler was disabled, unsure why, not upset about it, but it came with an error in the code I was updating, and now the changes in the code won't take... it is like the server is taking a few days to respond to file changes for some reason

  • go to includes/config.php and comment both lines: define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src'); AND define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat'); – Anil Suthar May 10 '16 at 5:59
  • As stated in edit above, I have tried commenting and uncommenting the specified lines with no luck – Kender May 13 '16 at 17:25
  • compiler disabled, afraid to re enable it to test it, see edit 2 – Kender May 19 '16 at 18:53
2

Okay. I found my problem

APC Cache was enabled on the server, preventing files from updating immediately, hopefully this helps someone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.