1

I am working on a Magento Website i.e. Website Link. The issue I am facing is when I click on the logo or trying to get the base URL inside the template files the base URL comes with default prefix like http://www.theemergencyboltcompany.com/default . I have tried to figure out the issue inside .htaccess and database. But the default keyword is not defined anywhere.

I want to know why this default prefix comes with base URL.

Another issue : Website is using MST menupro Extension to manage navigation menu. On the frontend some navigation menu links comes with Default keyword and some are not. The link that comes with default keyword working fine whereas another link shows 404.

Please help me out how do I figure out the issue Or Fix the issue.

Many Thanks in advance.

  • disable the store code displaying in system > config > web you can find it – Manikandan May 6 '16 at 11:54
  • Please answer it. Then I will be able to accept it – Sanchit Gupta May 6 '16 at 12:01
  • Added it as answer – Manikandan May 6 '16 at 12:07
2

Goto Magento Admin panel

System > Config > Web > Add Store Code to Urls

Then change it as NO then the store code won't be added to your url

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.