4

As a newbie, I just installed the M.Community Full Release with Sample Data 2.0.5 on Win8 64bit with Xampp -- all went well so far, except arriving in the backend panel the "Admin Icons" are replaced by not resolvable symbols because the font is missing, in the setup.css, a font "Admin Icons" is referenced, which doesn't exist in any folder.

But basically, I can't find any font in any folder that actually displays icons (a Windows prob?).

enter image description here

| improve this question | | | | |

10 Answers 10

8

It seems that some css and fonts files are not generated properly. You need to do the folowing

  1. Remove pub/static
  2. Remove var/cache
  3. Remove var/composer_home
  4. Remove var/generation
  5. Remove var/page_cache
  6. Remove var/view_preprocessed
  7. run php bin/magento setup:static-content:deploy
| improve this answer | | | | |
  • 1
    Thank you sooo much! At first I had this memory_limit runtime error (at 132M, yeah right)...but upon system restart (Windows, rrrr) it ran through again and now everything is there. BIG eyes...thank you so much for the quick and of course correct reply - worked like a charm, my dashboard is a-okay! – tutuKid May 9 '16 at 13:42
  • i faced same problem but when i run the command 7. it shows this msg "Failed loading /usr/local/lib/php/extensions/no-debug-non-zts-20121212/opcache.so: /usr/local/lib/php/extensions/no-debug-non-zts-20121212/opcache.so: cannot open shared object file: No such file or directory" – Wasif Khalil May 17 '16 at 20:30
  • upvoted this answer is worked! – Josua Marcel Chrisano Sep 27 '17 at 13:34
  • I dont understand how to run php bin/magento setup:static-content:deploy – Cory Nickerson Sep 27 '17 at 20:53
  • @CoryNickerson you must login to server using shell and then go the root folder of your magento installation. for there you can run this command – Shaheer Ali Sep 29 '17 at 10:39
12

Open up app/etc/di.xml find the path

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink

and replace it with

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Note: Remove entire files and folder under pub/static except .htaccess

| improve this answer | | | | |
4

Open up app/etc/di.xml find the path

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink

and replace it with

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Then go to var\cache this folder remove all file

| improve this answer | | | | |
3

I encounted this issue when using a CDN network, I added the following to allow cross origin sharing within the html/.htaccess file

<FilesMatch "\.(ttf|ttc|otf|eot|woff|woff2|font.css|css|json)$">

Header always set Access-Control-Allow-Origin "*"
Header always set Access-Control-Allow-Methods "GET"
Header always set Access-Control-Allow-Headers "X-Accept-Charset,X-    Accept,Content-Type"

</FilesMatch>

It seemed to be an issue with the default Magento htaccess fle not allowing certain font types which caused the issue. I tried the solutions above with no success but this worked for me.

Perhaps this will help. I flushed the cache and re-indexed after adding

| improve this answer | | | | |
2

To show backend and frontend css, font and icon , I used this solosion:

Remove pub/static //not .htaccess
Remove var/cache
Remove var/composer_home
Remove var/generation
Remove var/page_cache
Remove var/view_preprocessed

Then open up app/etc/di.xml find the path

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink
 and replace it with Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

And finally run this:

php bin/magento setup:static-content:deploy 
| improve this answer | | | | |
1

Open app/etc/di.xml

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink

and replace it with

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

then Remove entire files and folder under pub/static except .htaccess

and it will show up

| improve this answer | | | | |
1

check the admin panel language, and be sure to run di-compile in that language ex.:

php bin/magento setup:static-content:deploy -f en_US en_GB

| improve this answer | | | | |
0

To show backend and frontend css, font and icon, follow these 2 steps:

1.Run the deploy or forcefully deploy command:

php bin/magento setup:static-content:deploy

OR

php bin/magento setup:static-content:deploy -f
  1. Make sure that .htaccess file exists in var & pub/static folders after deploy, if not exists then copy and paste from the Magento original setup.
| improve this answer | | | | |
0

i tried all solutions and still not working, and it is only anything related for css font icons .. ?

| improve this answer | | | | |
  • it was solved bu i was not able to see the new changes du to Varnish cache, as soon i cleared the cache the changes took effect .. thanks to all (: – Saleh Abdulaziz Jun 14 '19 at 21:34
0

plz reply quickly..i faced 2 problems.. magento icons missing and 2nd website homepage also not showing... how i resolves these issues through c-panel.enter image description here

enter image description here

| improve this answer | | | | |
  • plz reply quickly..i faced 2 problems.. magento icons missing and 2nd website homepage also not showing... how i resolves these issues through c-panel. – Ushna Butt Apr 28 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.