4

We recently upgraded our 1.8 installation to 1.9.2.4 and now when we try to add a product to an order via the admin area (Admin > Sales > Orders > Create New Order) none of the set up Payment methods appear.

enter image description here

As far as I can see all configuration is correct. I've found a similar question here but there is no answer and the suggestions do not work either.

  • You can refer this answer I think it will be helpful for you. – Manikandan May 4 '16 at 10:09
  • @Manikandan which file do I add that comment to? I've seen it suggested before – evilscary May 4 '16 at 10:11
  • Mage_Payment_Model_Method_Abstract in this model you can find the code.@evilscary – Manikandan May 4 '16 at 10:14
  • @Manikandan I found the file and added the code but still no luck. No payment methods appear at all in the admin area, but all the method models are set to $_canUseInternal = true – evilscary May 4 '16 at 10:19
  • add the code which i have refereed from a developer answer@evilscary – Manikandan May 4 '16 at 10:27
2

Each payment method model supports a member called $_canUseInternal. This decides if the payment method can be used in the backend.
So you need to add this in the payment method model

protected $_canUseInternal = true; 

But chances are you will need more than that, depending on the payment method. You may need to create a block and/or a template for admin use.
Some of the payment method might not be designed to work on the backend.

If you need a method just to appear on the invoice and no actions behind it then you can create your own. Here is a nice tutorial for creating one.
Just make sure you set to it

protected $_canUseInternal = true;
protected $_canUseCheckout = false;
protected $_canUseForMultishipping = false; 

so you can use it only for frontend.

|improve this answer|||||
  • None of the default payment methods appear in the admin area at all. All I need is for any payment methods to appear! – evilscary May 4 '16 at 10:38
  • lucdebrouwer.nl/… – Asheem Patro May 4 '16 at 10:48
  • follow the steps in this link. – Asheem Patro May 4 '16 at 10:49
  • I have already run through that guide with no change – evilscary May 4 '16 at 10:53
  • which payment options you are using for your site. – Asheem Patro May 4 '16 at 11:34
1

In magento every payment method extend Mage_Payment_Model_Method_Abstract and has the below member variables

protected $_canUseInternal = true; //This can use in admin 
protected $_canUseCheckout = true; //This can use in onepage checkout 
protected $_canUseForMultishipping = true; //This can use in multishipping

By default all are true

If you wanna use method for admin only then just use below code

protected $_canUseInternal = true; //This can use in admin 
protected $_canUseCheckout = false; //This can use in onepage checkout
protected $_canUseForMultishipping = false; //This can use in multishipping
|improve this answer|||||
  • These are all enabled, no payment methods appear in the admin area at all. – evilscary May 4 '16 at 10:37
  • Is there any third party module installed for payment method? if so means disable it and check – Manikandan May 4 '16 at 10:41
1

I realise I never accepted an answer for this.

It turned out to be a clash between two modules we had installed that was causing the options in question to be hidden.

After updating the modules the problem was solved.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.