1

I have a problem with a cms homepage in my store. So, in my store i deleted the menu item from home page and I kept only the menu items of the individual product categories. But for first page of my store, in System, i selected "Home Page Custom" for default page.

I have already selected the CMS page viewable in Italian and English language of the store. But still, when I go to my store at www.site.com/store i see the template of my site with menu and footer but without the content of my CMS Page. Only when i selected language of my store in Italian or English i see the content of my CMS home page.

How can I view the default content of my CMS Page without having to select the language?

Thank you very much

enter image description here

  • Have u checked by setting the home page for default store view. – Asheem Patro May 4 '16 at 8:44
  • Yes man, i checked the home page but i can see the content only when i select a language of my store... – Gabriel91 May 4 '16 at 8:45
  • Check my answer – Asheem Patro May 4 '16 at 8:46
  • Are you use the CMS page you selected is visible on all store views, and is set to Enabled? Run a reindex and flush cache after. – Steven J Oct 27 '17 at 18:00
1

I finally found the problem. In my .htaccess file I had the following entry.

SetEnv MAGE_IS_DEVELOPER_MODE 1

By commenting this out the front pages returned.

I hope this helps someone in the future.

And also check for the static blocks on the home page then check the stores and set it as the CMS home page.

  • I haven't this entry in my .htaccess. I've already selected my cms page as the default page in System -> Web but without success...What else could I do? – Gabriel91 May 4 '16 at 8:52
  • Can you send one screenshot of the System -> Web -> Default Pages – Asheem Patro May 4 '16 at 8:55
  • Adding image. It is possible that the cause is to have deleted the home menu item? Thanks. – Gabriel91 May 4 '16 at 9:10
  • Asfar i know ,htaccess have no SetEnv MAGE_IS_DEVELOPER_MODE 1 we use this to debug or same form index.php (ver 1.x) – inrsaurabh Jan 7 '18 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.