1

I have recently created the new Product category and a simple product in it and shows it on front end using block but it giving this error "There are no products matching the selection." as the product is present there still it giving me error:

I have tried by clearing the cache and login and logout again but still the same issue.

Any Help in this issue.

Thanks

  • Add your code here – Prashant Valanda May 2 '16 at 13:26
  • Make sure you give permissions to that block in ADMIN >> SYSTEM >> PERMISSIONS >> BLOCK – PG Sutariya May 2 '16 at 13:28
  • are you using a static block assignment to the category from admin or using some code to display in the frontend. please mention how you are trying to display product to frontend. – Ashish Madankar M2 Professiona May 2 '16 at 13:28
  • also check 'visibility' and 'inventory' options – Triyugi Narayan Mani May 2 '16 at 13:31
  • @Ashish Madankar I have created a new template for the products and get them as like this: <?php echo $this->getLayout()->createBlock('catalog/product_list')->setCategoryId(78)->setTemplate('catalog/product/sample.phtml')->toHtml(); ?> – Xabby May 2 '16 at 13:38
1

I think its visibility is hideen Go to magento admin panel menu

Catalog => Product => Select product and got to product information There is drop-down Here select one of these option

  • That's all ok i have checked it – Xabby May 2 '16 at 13:40
  • i am using a template and get all the products as like this: <?php echo $this->getLayout()->createBlock('catalog/product_list')->setCategoryId(78)->setTemplate('catalog/product/sample.phtml')->toHtml(); ?> – Xabby May 2 '16 at 13:42
  • There is a re-index process is remaining is that the issue? – Xabby May 2 '16 at 13:44
  • make sure product status is enable and there is quantity. $category = new Mage_Catalog_Model_Category (); $category->load ( $catid ); $prodCollection = $category->getProductCollection (); – Gurpal singh koundal May 2 '16 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.