0

After clicking manage categories in the back end of magento I have received this:

There has been an error processing your request Source model "mageplaza_seo/source_robots" not found for attribute "meta_robots"

Trace:
#0 /home/tapisdor/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(387): Mage::exception('Mage_Eav', 'Source model "m...')

Error log record number: 1450270382448

I understand it has to do with an extension that I have removed. But if I removed it on magento connect manager, why is this showing up?

1

This extension have create an attribute meta_robots which Source model model was exits at system.

As you have removed this attribute that this attribute does not find it Source Model.

So,you need to delete this attribute from eav_attribute table from data table using below code

delete from eav_attribute where attribute_code='meta_robots'

Also you remove those code which call this attribute

| improve this answer | |
  • Hi how do I delete it on the back end of magento from table without using code? since i do not have access to code. – Sam A May 2 '16 at 18:05
  • run this code at mysql database of your magento instance – Amit Bera May 2 '16 at 18:06
  • Thanks lot Amit for helping @SamA I felt sad when my solution did't worked for him. Now i am sure he will get solution :- ) – Baby in Magento May 2 '16 at 18:49
  • Is the database name mg_catalog_eav_attribute? – Sam A May 7 '16 at 20:31
0

if you dont required the attribute : meta_robots , just delete it and check the problem is still there or not

| improve this answer | |
  • I delete it under Catalog-attributes-manage attributes. The result was: There has been an error processing your request Source model "mageplaza_seo/source_robots" not found for attribute "meta_robots" Trace: #0 /home/tapisdor/public_html/app/code/core/Mage/Eav/Model/Entity/Attribute/Abstract.php(387): Mage::exception('Mage_Eav', 'Sour – Sam A Apr 30 '16 at 15:52
  • Please help the problem is still there – Sam A Apr 30 '16 at 16:15
  • check Amit answer. – Baby in Magento May 2 '16 at 18:52
  • Is the database name mg_catalog_eav_attribute? – Sam A May 10 '16 at 0:24
  • @SamA you dont need to worry about which database. please take the backup of current database, than run this query : delete from eav_attribute where attribute_code='meta_robots' – Baby in Magento May 10 '16 at 5:11
0

go to admin Catalog->Attributes->Manage Attributes and delete "meta_robots" attribute. Any manipulation with code and MySql.

| improve this answer | |
  • It looks like your answer is incomplete - what do you mean by "any manipulation with code and MySql"? – tjons Nov 20 '16 at 3:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.