-1

When trying to upgrade using Web Interface, the readiness check fail with this error:

PHP Settings Check Need Help? PHP Documentation Your PHP Version is 5.6.20, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

That is a nonsense since that variable is already -1:

enter image description here

How can I solve it?

1 Answer 1

1

It's barely noticeable, but at the top of the image you posted, it appears the version is 5.6.13. Since the wizard is saying you're running 5.6.20, it seems that your Magento install is pointing to a different php install.

7
  • you are completely right. For some reason, PHP was updated automatically to version 5.6.20 using yum, but strangely, all websites continue using 5.6.13. However, magento update uses cron to do the update, so it uses PHP 5.6.20. Do you think this is the problem even if cron uss 5.6.20?
    – jstuardo
    May 3, 2016 at 20:54
  • it appears that way. you need to check the 'always_populate_raw_post_data' setting for your php 5.6.20 install. I believe cron uses the cli version of php. If you have ssh access, you can run 'php -i | grep always_populate_raw_post_data' to see what the setting is for php cli. May 4, 2016 at 19:48
  • when using "php -i" command, appears that variable is -1 and PHP version is 5.6.13. I don't know why Magento installation is thinking I have 5.6.20.
    – jstuardo
    May 4, 2016 at 21:34
  • If you're hosting allows, different php versions can be specified for each site/domain you have. This is usually possible to change in CPanel or WHM. Here is a link with instructions : [link]inmotionhosting.com/support/website/php/… May 4, 2016 at 21:45
  • This is a propietary control panel called Ferozo. It allows multiple versions but the last is 5.6.13. I don't know why 5.6.20 is being detected.
    – jstuardo
    May 5, 2016 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.