4

I've looking this solution for hours! The v3 is way to old and buggy. Anyone has been able to upgrade it to v4.3?

  • Old? Probably by version. Buggy? What is buggy? Can you share examples where v3 actually is an issue while v4.3 would be not? And finally, what hinders you to use it in parallel and require.js it where you need it? And looking for the solution for hours: Which concepts did you follow, what has already proven for you non-working? Could you please elaborate? – hakre May 23 '16 at 20:38
  • Thanks! I mean, that v3 is old, and I can't find for example Youtube plugins that work with the new Youtube embed iframe way. – Oscar Azpeitia May 24 '16 at 0:42
  • And what have you tried so far,. what was the outcome and how is the outcome insufficient to what you'd like to do? If you give the question more substance, it's easier for others to provide more valuable feed or even an answer. – hakre May 24 '16 at 8:02
2

I don't think it's a good idea to upgrade any component of magento.
Magento 2 has some plugins for tinymce that might not work on version 4.

| improve this answer | |
  • I agree with @Marius, Magento probably has a good reason that it still uses an older version of TinyMCE. Could also possibly be a remnant of much of the ported code of Magento 1. – Giel Berkers Dec 20 '16 at 8:18
0

I have written a module which upgrades the editor to TinyMCE 4 and also covers the customized plugins (widgets, variables, images), currently working for Magento 2.1 and 2.2.

For those who want to check it out: https://github.com/pavelleonidov/magento2-tinymce4

| improve this answer | |
  • Good stuff, do you have a spell checker in the module as plugin? – Sander van Zuidam Jul 4 '18 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.