0

My Header images are 404ing only in the OnePage checkout when you view cart or purchase your selected items. As shown in Here

The images are working site-wide except for that page.

The correct path is http://*****.com.au/skin/frontend/rwd/default/images/paypal.png

The OnePage Checkout is pointing to http://*****.com.au/checkout/onepage/index/skin/frontend/rwd/default/images/paypal.png

/www/checkout does not exist in my folder structure?

Is there a file I can edit to point to the right images

EDIT: This is actually not working in alot of my site. If items are viewed from the homepage it is fine, as soon as I view it from my Categories list, the images are again 404ing.

1

Maybe probem in your configuration of Base Skin URL or Base Media URL. Check your configuration of secure/unsecure url in System->Configuration->General->Web->Unsecure

More information you can find here

  • Definitely setup correct as per that link. – SixShields Apr 28 '16 at 7:02
  • It's look like path to image set incorrectly in your template file, such as <img src="/skin/frontend/rwd/default/images/paypal.png" />, but it must be <img src="<?php echo $this->getSkinUrl('images/paypal.png'); ?>" /> – Ihor Klymchuk Apr 28 '16 at 7:51
  • Even if your src didn't correctly use the getSkinUrl function it would seem that the src does not start with a "/" (which will default to the site root) as the url is just concatenating with the current URL. – Jon Holland Apr 28 '16 at 9:27
  • Thankyou my problem was the forward "/" before the src. Fixed. – SixShields Apr 29 '16 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.