3

I am calling newsletter in static block by below sort code

{{block type="newsletter/subscribe" name="footer.newsletter" template="newsletter/subscribe.phtml" }}

its was working, but suddenly stopped to show the form. I have checked the permission for newsletter/subscribe in permission section where it is set to "allow" as well.

  • What did you change? – Klettseb Apr 27 '16 at 11:12
  • @Klettseb i did not change any thing..all my static block sort code stopped working. – Deepak Kumar Apr 27 '16 at 11:27
1

I took me a while to found out why the block tag isn't showing the newsletter, but you can find your answer here: https://stackoverflow.com/questions/3420285/newsletter-signup-on-cms-page-in-magento

Like epson121 mentioned, you have to enable the block in CMS -> Permissions (or add it, if it's not there).

The block name is of course: newsletter/subscribe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.