2

Magento 1.9 admin and frontend always shows 404 not found

404 not found randomly shows when I'm on admin or on frontend but when I refreshed that certain 404 page it will work fine.

I tried reverting the .htaccess to its original code but it still exist. Tried also disabling/removing some extensions but no luck.

enter image description here

Thank you.

  • check url when admin or frontend working and when 404 error comes. – denish vachhani Apr 27 '16 at 5:02
  • @denish it is random.. when I clicked sometimes on an order or when I'm saving a product info change.. – Mhel Apr 27 '16 at 5:52
  • in url index.php/ is present when 404? – denish vachhani Apr 27 '16 at 5:54
  • no its not present.. – Mhel Apr 27 '16 at 5:55
  • i think there is an issue – denish vachhani Apr 27 '16 at 5:59
1

Try these steps:

  1. Check if you are accessing the correct admin url (see admin...frontName node in app/etc/local.xml file)

  2. Try to run the sql below:

SET SQL_SAFE_UPDATES=0;
SET FOREIGN_KEY_CHECKS=0;
UPDATE `core_store` SET store_id = 0 WHERE code='admin';
UPDATE `core_store_group` SET group_id = 0 WHERE name='Default';
UPDATE `core_website` SET website_id = 0 WHERE code='admin';
UPDATE `customer_group` SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';
SET FOREIGN_KEY_CHECKS=1;
SET SQL_SAFE_UPDATES=1;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.