1

We are not getting the UPS Shipping Methods in Checkout Section. When We have change the Mode as Development it's working correctly, after changing the Mode as Live it's not working (UPS Shipping Methods) and not getting in Checkout Section. And earlier it's working fine either Mode as Development or Live. We have recently changed the SSL Certificate for Magento Website. From now when I have change the Mode as Development it's working and getting shipping methods, but Live Mode it's not working.

enter image description here

Could you please suggest me on this.

0

I'm not sure what you mean by Development vs Live. The default Magento UPS module has no settings for Live vs Development. So, I'm assuming you're referring to a development environment vs a live environment. Since these are different, you should also check to make sure you have entered a proper shipping origin. UPS relies on that to deliver shipping results.

If you're using the default UPS module, you should turn on the Debug feature and see if the system.log file records any errors. If you're using a third-party module, then it may indeed have a Development vs Live configuration. In that case, you have to use different credentials for UPS Dev vs Live.

  • I have enable the Debug feature and it's created shipping_ups.log file. And the request is the same for Mode Development and Live When Mode Development the result is came, but Live Mode it's not came. and I have checked my system.log file there is no errors belongs to this. – Manoj Kumar Apr 26 '16 at 5:42
  • please see my updated question. – Manoj Kumar Apr 26 '16 at 10:24
  • Looks like you're using an older version of Magento. Later versions have no User/Password needed to query UPS. Or else you're using a third-party extension. You do have to have different account credentials with UPS for using Live or Development queries. Are you entering different credentials? – novusweb Apr 26 '16 at 21:48
  • @novusweb My store running in India, so all products weight in KGS, if i try to UPS for international customer i am getting an error like : This measurement system is not valid for the selected country, How can i solve this issue? – zus Feb 14 '18 at 10:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.