1

I'm using Magento 1.9.2.4 on a CentOS VPS.

I'm trying to copy my Magento store from a web hosting server to my backup server(The VPS)

I ensured mod_rewrite was on for apache, the front-end now works properly. But now i'm unable to access the admin. Or i can but under really weird circumstances.

For instance, i'll access the admin panel typing in

/IP ADDRESS/Website/admin

and the panel loads up. I try in credentials but then the web url goes to

/websiteindex.php/admin/dashboard/index/key`

To fix this, i manually add a / between website and index.php. Appearing like /website/index.php. It works for that single page, but if you click on something else, the intialy error will appear.

I looked into the apache Error_log and it just mentions

script '/var/www/html/websiteindex.php' not found or unable to stat

Things I've tried:

  • Ensured Mod_rewrite is working. Works on the front end.
  • Applied MYSQL Query search mentioned here Error 404 - Can't access backend after moving to new server
  • .htaccess has AllowOverride all at <directory "/var/www/html>
  • Access admin panel by typing /IP ADDRESS/website/index.php/admin. Initial error occurs

Any ideas?

2

The issue is just because you may forget to add a slash ( ‘/’) at the end of base url in system configuration settings.

/IP ADDRESS/Website/

Please try adding the same and test it again.

  • Looks like this was the solution after all. I did applied this to my VPS Server and it worked. The first i applied it, changes didn't take effect even after restarting. I cleared the Magento Cache by removing the /var/cache folder and it works fine now! – Dequan W Apr 25 '16 at 22:18
0

When you transfer magento1.9 website from live server to localhost, make sure in root folder .htaccess file exists. If not than you wont be able to access admin panel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.