0

I am trying to reindex the data in magento via SSH i have memory_limit = 1024M. But when i try to reindex the data it stopped suddenly and Killed comes written on screen. I have imported near about 50000 products . Before import, indexing was fine. Please answer if anybody already been through this kind of error.

Thanks

3
  • 1
    what is the message you got in you SSH terminal? Commented Nov 27, 2013 at 11:58
  • In the next line of SSH terminal the only message written is "Killed".
    – Sarvagya
    Commented Nov 27, 2013 at 12:47
  • and this comes not from Magento. at least not from its generic part. Commented Nov 27, 2013 at 13:22

1 Answer 1

3

This answer on stackoverflow might help.
Basically it means that the PHP process doing the indexing exceeds the memory limit you have on the server and it's killed by linux to prevent crashing the server

50K products is a lot and I'm not surprised it's causing issue when running the indexer under only 1024M of memory. The only solution will be to upscale your server or use an Amazone cloud instance for example to do the heavy lifting

4
  • Hello Marius and Sander i traced down the whole configurations of server and the increased the max_execution_time to 18000 and now i am able to re-index the data. Thanks a ton for your guidance.
    – Sarvagya
    Commented Nov 28, 2013 at 13:31
  • Hi Sarvagy, I hope you only did that for this one specific script and not for the default execution time? Commented Nov 28, 2013 at 13:46
  • Hello Sander, i have set this at php.ini of my server and .htaccess of my website . i did anything wrong ??
    – Sarvagya
    Commented Nov 30, 2013 at 13:06
  • A default execution time of 300 minutes can potentially be an issue for your server. When a page loads extremely slow you want to timeout to kick in and prevent the server from having long processes it can't handle. I would suggest using the shell script for reindexing through the commandline and setting the timeout back Commented Nov 30, 2013 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.