0

A few months ago I changed the Use Categories Path for Product URLs to no to avoid duplicate urls.

Products had .html at the end of the url with or without the category. At this time, I do still have the .html sufix enabled but I've noticed that the new products I upload to Magento doesn't have it.

What I would like is to show all products with .html at the end and of course, without the category on the path.

A screenshot of the configuration as it is at this moment:

enter image description here

  • if you have multiple store then change the scope to store and check the settings – Asish Hira Apr 22 '16 at 11:03
  • I do only have one store – danibg Apr 22 '16 at 13:12
0

I found why it did not have the .html at the end. Magento products needed to be reindexed. I reindexed these products, not throw Magento admin panel, but with Store Manager. This tool has the option of reindexing products after importing them. Everything looked to be fine with that reindex but it seems it did not.

So I just reindexed products throw Magento admin panel and then updated cache and it is fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.