2

I am installing Magento 2 on Bitnami WAMP Stack. However, soon after starting the installation it throws a list of errors and I am unable to fix this one:

PHP Settings Check
Your PHP Version is 5.6.20, but always_populate_raw_post_data = 0. $HTTP_RAW_POST_DATA is deprecated from PHP 5.6 onwards and will be removed in PHP 7.0. This will stop the installer from running. Please open your php.ini file and set always_populate_raw_post_data to -1. If you need more help please call your hosting provider.

I have checked the php.ini but the always_populate_raw_post_data is already set -1.

I also ran php.info, it shows this: enter image description here

Where's the problem?

  • After making your change, did you restart apache? – Aric Watson Apr 20 '16 at 19:18
  • In your screen capture, it's set to 0. In addition to restarting the web server, make sure you modified the correct php.ini. You must modify the one used by the web server, as indicated in phpinfo.php by Loaded Configuration File – Steve Johnson Apr 20 '16 at 20:23
  • @TallalHassan some times it might cause even though you have modified php.ini file So, better to restart your system and check the configuration settings by opening http://localhost/phpinfo.php. – Bojjaiah Apr 21 '16 at 5:02
2

Well making changes in the php.ini or adding php parameter in the .htaccess didn't resolve my issue .
I created .user.ini file on the web directory root and added this : always_populate_raw_post_data = -1

Volla! issue was resolved. Let me know if you guys have any question.

1

First of all find the path of php.ini configuration file. You can find php.ini file path by using phpinfo(). Once you find the path of file. Go to that path and open the file and find always_populate_raw_post_data and set always_populate_raw_post_data = -1 save and restart the server.

if the issue still not gone you can add the always_populate_raw_post_data = -1 in your .htaccess file which is located at the root directory of Magento then restart the server.

Now this will work.

1

Remove semicolon(;) before always_populate_raw_post_data in php.ini file. Make sure you are changing in correct loaded configuration file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.